Module 1:

Styles and Advanced Object Tools

This module contains:

- **Section 1: General Style Information**
  - Using the Style Manager
  - General Style Properties
  - Working with Materials
  - Classifications
  - Display Properties

- **Section 2: Wall Tools**
  - Creating Wall Modifiers
  - Changing Wall Modifiers
  - Miscellaneous Wall Tools
  - Complex Wall Shapes

- **Section 3: Advanced Sections and Elevations**
  - Horizontal and Vertical Sections
  - Subdivisions
  - Adding and Modifying Linework
  - Modifying Material Boundaries
Section 1: General Style Information

In this section you will learn how to:

- Use the Style Manager.
- Set up general style properties.
- Create materials.
All AutoCAD Architecture styles are grouped together in the **Style Manager**, which gives you one place and one main method for creating styles. The exact information you add or edit in a style varies according to the type of object, but the basic procedures are the same for all.

- An easy way to access the Style Manager is to use the tools for individual styles in the Tool Palettes window. Right-click on the tool and select **Wall Styles…**, **Stair Styles…**, or whatever type of object the tool creates. Other styles are automatically filtered out.

- To access the Style Manager with all object types available, select **Format>Style Manager** from the pull-down menu.

- The manager list is divided into three folders for different types of styles: **Architectural Objects** (such as Wall and Stair styles), **Documentation Objects** (such as Schedule Table and Zone styles), and **Multi-Purpose Objects** (such as Profiles and Material Definitions).

- To access pre-defined styles that come with AutoCAD Architecture open a drawing in the Style Manager. Click **Content** in the Look in: pane and select the **Styles\Imperial** or **Styles\Metric** folder.
Style Manager Options

The Style Manager works like Windows Explorer. You can show or close various levels in the tree view to the left side. Information about the items selected displays on the right side.

- If you select a **Drawing** on the left side, you see information stored in the drawing properties including the Title, Subject, Author, and Keywords. This information can be set in the Properties dialog box (File>Drawing Properties).

- If you select a **Style Group** on the left side (such as Wall Styles or Stair Styles), you see a list of the styles of that type defined in the drawing.

- If you select an individual **Style** on the left, you see tabs where you set up various aspects of the style, as shown above.

- The exact listing of the tab options for styles varies according to the object selected.

- The **Floating Viewer** opens an additional window where you can view the style using all typical 3D viewing and shading tools.

- You can quickly access an individual style’s properties. Right-click on an object in the drawing and select **Edit <object> Style**. This opens the specific properties for that style without opening the Style Manager.
## Style Manager Toolbar Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Drawing</td>
<td>Starts a new drawing based on the default template.</td>
</tr>
<tr>
<td>Open Drawing</td>
<td>Opens an existing drawing. Use to access styles in other drawings, for example, the AutoCAD Architecture drawings with extra styles such as Space styles, Schedule Table styles.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies a drawing, folder, style group, or style to the clipboard. You can copy entire style groups from one drawing to another. If there are duplicate names, you can leave the original styles intact, overwrite the styles, or give the new styles a name.</td>
</tr>
<tr>
<td>Paste</td>
<td>Pastes a drawing, folder, style group, or style from the clipboard into the current drawing or a different drawing. It is only available if you have copied something to the clipboard.</td>
</tr>
<tr>
<td>Edit Style</td>
<td>Opens the editing tabs for the style if it was not already open.</td>
</tr>
<tr>
<td>New Style</td>
<td>Creates a new style.</td>
</tr>
<tr>
<td>Set From</td>
<td>Switches to the drawing window where you can select an object if a new style you are creating require it.</td>
</tr>
<tr>
<td>Purge Styles</td>
<td>Removes unused styles from the drawing. It can be run on the entire drawing, on folder, on a style type, or on individual styles. In a dialog box, it prompts you to select the styles you want to purge. If only one style is selected, it automatically purges the style without prompting you for anything else. You cannot purge the “Standard” style or a style that is in use.</td>
</tr>
<tr>
<td>Toggle View</td>
<td>Switches the tree view between showing drawings as the main categories and showing the style groups as the main categories.</td>
</tr>
<tr>
<td>Filter Style Type</td>
<td>Filters the selected style type. It is automatically on if you opened the Style Manager using one of the style commands (such as Wall Styles). If all style groups are showing, select a style group and then apply the filter to see only that group.</td>
</tr>
<tr>
<td>Views</td>
<td>Enables you to select between Large Icons, Small Icons, List, and Details. Use Details to see the descriptions of styles as well as their name. Available with Objects and Projects.</td>
</tr>
<tr>
<td>Inline Edit Toggle</td>
<td>Toggles between showing tabs for editing styles or the Viewer/List tabs similar to the previous release of AutoCAD Architecture.</td>
</tr>
</tbody>
</table>

- Most of these options are also available through the right-click menu.
To Create a New Style

1. Open the Style Manager or start the appropriate style command, such as **Wall Styles**, which automatically filters out the other styles.

2. Click (New Style) or right-click on a style or style group and select **New**.

3. A new style name appears on the right side, highlighted in blue. Type a new name for the style.

4. The new style options display in the right pane. If the name displays instead, click (Edit Style) or right-click on the new style name and select **Edit…**.

5. Fill out the individual style information in the tabs.

   - The Style Properties dialog box has many tabs or sections, depending on the complexity of the style. Five tabs occur for most styles and work the same way for all: **General**, **Materials**, **Classification**, **Display Properties**, and **Version History**.

To Copy a Style

Often you need to create a style similar to an existing one. Rather than starting from scratch, copy the style and then make changes to the copy.

1. Select the style you want to copy.

2. Click (Copy) or right-click and select **Copy**.

3. Select the style group in the drawing where you want to paste the copy (it can be the same drawing). Click (Paste) or right-click and select **Paste**.

4. Rename and edit the style as needed.

   - You can also copy styles and style groups from one drawing to another using “drag-and-drop” in the Style Manager.

To Copy and Assign a Style

To quickly create a new style based on an existing object in your drawing, use Copy Style and Assign.

1. In the drawing, select the object you want to copy.

2. Right-click and select **Copy <object> Style and Assign**.

3. In the Style Properties dialog box, rename the style, and change the properties as needed.

4. Click **OK**. The new style is applied to the selected object.
In this practice you will look at the different options in the Style Manager and make a new Wall Style. Estimated time for completion: 10 minutes.

1. Open the drawing Adobe_House.dwg.
2. Open the Style Manager in the pull-down menu (Format>Style Manager).
3. In the tree view on the left, expand the Architectural Objects folder for the current drawing and look at the different style groups available.
4. Select Wall Styles in the list and expand it.
5. The only wall style defined in the drawing is Standard. Wall styles are imported to the drawing when you use one of the Wall tools from the tool palettes.
6. Click to close the Style Manager.
7. In the Tool Palettes window Walls tab, draw several walls of different styles. (You can also right-click on a wall tool and import the style without having to draw one.)
8. Right-click on one of the Wall tools and select Wall Styles....
9. This time the Style Manager opens directly to Wall Styles with the other styles filtered out. You also see the styles that were imported into the drawing when you drew the walls.

10. Select one of the wall styles in the tree view. On the right side you should see general information about that style.

11. Switch between the different tabs in the dialog box to get a feel for the various parts of the style. End on the General tab.

12. Right-click on a different wall style in the tree view and select New. Name the new style Adobe.

13. Click to close the Style Manager.

14. Erase the walls you drew earlier.

15. Save the drawing for use in the next practice.
General Style Properties

The General tab holds important data where you cannot only name the style and add a description, but also add notes, assign keynotes used in annotation, and assign Property Sets used in schedules and Display Themes.

- The Version History tab of a style’s properties works with Project Standards. You can specify if you want the style to be checked or not when you are synchronizing project information.

Notes and Reference Docs

Click to open the Notes dialog box. The Notes tab enables you to add any notes you could want connected to a style. The Reference Docs tab enables you to attach documents to the style. For example, you could want to attach specifications or literature from a manufacturer. The documents can be any type of file including other drawing files.
Keynotes

Keynotes are a method of annotating drawings using a standard set of information across a drawing. Styles can have keynotes attached to the entire style or to individual components. When you use the keynote annotation tools and select a style with a keynote attached, it automatically assigns the number listed in the Style Properties.

To Add a Keynote to a Style

1. In the General tab of a style’s properties, click Select Keynote.
2. In the Select Keynote dialog box, find the keynote that relates to your object.
3. Click OK.
4. The keynote number is assigned automatically.

- The extensive database of keynotes that comes with AutoCAD Architecture is based on CSI Uniformat standards. You can also attach other databases of keynotes including the CSI MasterFormat 2004 standard.

- To help you find keynotes quickly, type a keyword in the edit field at the bottom of the dialog box and click (Filter) to display keynotes that use that word.

- Not every style has a keynote.

- Annotation objects do not have keynotes.
Property Sets

Property sets are non-graphical data that you can associate with objects in AutoCAD Architecture. For example, Door Styles have several property sets: DoorStyles, FrameStyles and ManufacturerStyles. The individual properties are a mix of information automatically gathered from the design of the style and items that you can edit. This information can then be used by schedules and Display Themes to present the data.

- These properties can be associated with individual objects but should be associated with a style if the information applies every time the object is added to a drawing.

To Add A Property Set

1. In the General tab, click Property Sets...
2. In the Edit Property Set Data dialog box, click (Add Property Sets).
3. In the Add Property Sets dialog box, check the property set(s) you want to load and click OK. The available sets vary according to the object you are working with.
The property sets display in the Edit Property Set Data dialog box.

4. Click **OK** to return to the Style Manager.

If the **(Add Property Sets)** button is grayed out all available property sets have been added to the style. However, it could also mean that property sets have not been loaded in this drawing. The fastest way to load a property set is to insert an object that has the set into the drawing. The Standard object styles rarely have property sets associated with them. Instead, you would need to insert a named style from the styles that come with AutoCAD Architecture.
Working with Materials

Materials in a 3D View

Materials control the display of objects in elevations, sections, and rendering. It is a good idea to set up materials for a project and use them consistently throughout it. AutoCAD Architecture comes with a wide variety of materials and you can make your own.

You can assign materials to individual objects, but typically materials are assigned to object styles. Many existing styles already have materials assigned to them. 3D objects such as walls can have materials assigned to them while annotation objects such as a structural grid do not. Within an object style, some items can support materials (such as a door panel and frame), while other objects (such as a door swing) do not.

- Material definitions define patterns for plan, surface, and section hatching as well as any settings used for rendering.

Surface Hatching in an Elevation
To Assign a Material to a Style

In the Materials tab of the style’s properties click in the pull-down menu next to a component and select from the list of available material definitions.

- Material Definitions must be preloaded in the drawing where you are creating the style.
- The components listed in the Materials tab vary according to the object type selected.

Click (Edit Material) to open the Material Definitions Properties dialog box where you can modify a material’s Display Properties.

Click (Add New Material) to create a new material that you can then edit.

- You can also create new materials and edit materials in the Material Definitions section under Multi-Purpose Objects in the Style Manager.
To Load Materials from Other Drawings

The list of Material Definitions in the Style Manager is limited to those that have already been imported in the drawing. You can access additional material definitions that come with AutoCAD Architecture.

1. Select Format>Material Definitions… in the Menu Bar. This opens the Style Manager, listing materials already loaded in the drawing.
2. In the Style Manager, click (Open Drawing).
3. In the Open Drawing dialog box, select the Content folder.
4. Select the Styles and the Imperial (or Metric) folders.
5. Find the drawing Material Definitions (Imperial).dwg (or Metric) and click Open.
6. In the Style Manager in the left pane, find the Material Definitions drawing and open it to the Material Definitions section under Multi-purpose objects.
7. In the right pane, find the materials you want to use, then drag and drop them into the current drawing under Material Definitions.
8. The materials are now available to assign to objects or styles in your drawing.
To Create a Material (Optional)

When you create a material you specify hatching patterns and scales for plan, surface, and section hatches as well as rendering materials for surfaces in 3D views and Live sections.

1. Select Format>Material Definitions… in the Menu Bar.
2. The Style Manager appears with Material Definitions filtered in.
3. Click (New Style) and type a name for the style.
4. Select the new style and switch to the Display Properties tab.
5. Select the Display Representation you want to modify with a new material style.
6. Click (Edit Display Properties).
7. In the Layer/Color/Linetype tab notice the types of Display Components that make up a property. Set the information as needed.
## Display Component Definitions

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Plan Linework</strong></td>
<td>2D items such as doorframes and the lines dividing various parts of a wall.</td>
</tr>
<tr>
<td><strong>2D Section/Elevation Rules</strong></td>
<td>Specify the way you want the materials to interact within 2D Sections and Elevations. Check the ones you want active.</td>
</tr>
<tr>
<td><strong>3D Body</strong></td>
<td>The linework in 3D views, for example the outline of a door panel.</td>
</tr>
<tr>
<td><strong>Plan Hatch</strong></td>
<td>The hatch pattern that shows within a plan section cut, such as concrete or brick.</td>
</tr>
<tr>
<td><strong>Surface Hatch</strong></td>
<td>The hatch pattern applied to surfaces in model and elevation views and areas not cut by a section line in section views.</td>
</tr>
<tr>
<td><strong>Section Hatch</strong></td>
<td>The hatch pattern applied to surfaces in sections that are cut by a section line.</td>
</tr>
<tr>
<td><strong>Sectioned Boundary</strong></td>
<td>For Live Sections. The section Boundary is the outline of the cut at the section line.</td>
</tr>
<tr>
<td><strong>Sectioned Body</strong></td>
<td>For Live Sections. The Section Body includes objects that are outside of the section.</td>
</tr>
</tbody>
</table>

8. In the *Hatching* tab you can set the hatch pattern scale and other information for Plan, Surface, and Section Hatches.
9. In the *Other* tab select the information for Surface Hatch Placement, Surface Rendering, Live Section Rendering, and 2D Section/Elevation Rules.

### Other Tab Options

**Surface Hatch Placement**
- Select the views you want to show surface hatching. By default it is set so the elevation views (Left, Right, Front, and Back) show surface hatch but the plan views (Top and Bottom) do not.

**Surface Rendering**
- Select the Render Material from a list of those available in the drawing. Click ![Browse...] to see an image of the material. Also in this area select the Mapping method: Default Mapping, Face Mapping, or Same as Surface Hatch.

**Live Section Rendering**
- Select the way Cut Surfaces and Sectioned Body Render Material displays in Live Sections. Click ![Browse...] to see an image of the material.
Classifications

Classifications offer an additional method of describing the objects in a drawing. For example, a wall can have a classification of Load Bearing or Non-Load Bearing for structural usage. You could also create classifications for different phases of a project.

- With classifications you can refine schedule content and control the visibility of objects. Display Configurations can be used to control the display of objects according to their classifications.

- Classifications can be attached to objects by style or set in the Extended Data tab of Properties when an object is selected.

- Classifications must exist in a drawing before they can be assigned.

- Classifications can have sub-classifications.

- AutoCAD Architecture includes one classification set, Uniformat II, found with the other content style drawing files.
To Create Classifications

1. Open the Style Manager.
2. Click to open the Multi-Purpose Objects section and select Classification Definitions.
3. Click (New Style) and type a name for the style.
4. In the General tab specify the name, and description, and add any notes as needed.
5. In the Applies To tab select the object styles to which this classification applies. For example, if you are doing a construction phase set, include all building object styles such as walls, doors, windows, and stairs. If you were doing a furniture and equipment vendor set, then select the Multi-view Block Definition.
6. In the Classification tab, click to include new classifications in the set.
7. Highlight the name of the classification and type a new name and description for each classification at the bottom of the dialog box.
8. If you need property sets applied to the classification, click Property Sets...

When you add additional classifications select the level under which you want to add them before you click Add.
To Assign a Classification to a Style

1. In the style, select the *Classifications* tab.
2. All classifications in the drawing that apply to the selected object display.
3. Click at the end of the classification name.
4. In the Select Classification dialog box, select the classification to apply to the style.
5. Click **OK** to close the dialog box.

To Assign a Classification to One Object

1. Select the object.
2. In the Properties palette select the *Extended Data* tab.
3. Click the worksheet beside the Classification name and select the one you want to use in the Select Classification dialog box.
Classifications and Schedules

Classifications can be used in scheduling as a column in a schedule table or as a filter to exclude or include items in a list. For example, you can have many doors in a renovation project but only some of them are new. If you have classified different doors or styles as New and Existing you can filter out the existing doors in the schedule. Or, you could include a column that specifies New and Existing if you want to comment or make some modifications to the existing doors.

You can assign classifications to schedules in the Style Manager in the Applies To and Classifications tabs.
Display Properties

The Display Properties tab holds information on how the style objects are displayed in the various viewport display configurations, where components of AutoCAD Architecture objects show different views in displays such as Medium Detail, Reflected, and Presentation.

Each object has System Default display properties (set in Display Manager>Representations by Object) that work with the display configurations. You can create overrides of the defaults by style in the Display Properties tab of the various styles dialog boxes.

For example, you might create a wall style that has a deep soffit. You would set the display properties so that the soffit shows in Plan display as a dashed line but prints out as a continuous line in the Reflected display.

- When setting or editing the display properties for a style, be sure that you check the style override option before making changes to the properties. Otherwise, you are changing the system default, not the style.
To Set Up Display Properties in a Style

1. Select the *Display Representations* type (Plan, Model, Reflected, etc.) that you want to modify and select the *Style Override* option.
2. As needed, click the *Edit Display Properties* button.
3. In the Display Properties dialog box, there are various tabs including but not limited to: Layer/Color/Linetype, Hatch, and Other. For example, the Model display representation of Wall Styles has only the Layer-related tab, while Plan could have more.

4. Fill out each as needed. In the Layer/Color Linetype tab, you could want to change the color used for each component. In the Hatch tab, you could set different hatches to represent different materials. In the Cut Plane tab, you could change the Cut Plane Height to show a special addition, such as a high chair rail. The information presented depends on the type of object and display representation selected.

5. Click [OK] to finish and save the changes.

---

### Changing Display Properties in Individual Objects

Display properties are typically set up by object or by style but you can also change them using individual objects. Select the object and open the Properties dialog box. The Display tab includes a list of the Display Components in an object. Select a specific component and then modify it according to the related properties.
**Practice - Working with Style Properties**

In this practice you will add a document, a keynote, and Property Sets to a style. You will set up materials to be used in the style as well as assign a classification. Estimated time for completion: 15 minutes.

**Task 1 - Work with the General Tab**

1. Continue working in the drawing *Adobe_House.dwg*.

2. Right-click on a wall tool and select **Wall Styles** to open the Style Manager.

3. Select the **Adobe** style to edit it. (If it is not in the drawing create a new style and name it **Adobe**.)

4. In the **General** tab of Wall Style Properties, add the description “1'-0" adobe wall furred out with 2" air space and 5/8" drywall on interior”.

5. Specify the Keynote: 03 31 00.M2. You can either type it in the edit field or click ![Select Keynote...](Select Keynote) to open the dialog box. Find this keynote under Division 03 - Concrete/Cast-in-place Concrete/Structural Concrete, near the bottom of the list.

6. Select ![Select Keynote...](Select Keynote). In the **Reference Docs** tab, click ![Add...](Add...) and attach the reference document *Adobe_Specs.doc* (in your class folder). Click ![OK](OK) to close the Notes dialog box.

7. Click ![Property Sets...](Property Sets...) and add the Property Sets for Wall Styles. Specify **Fire Rating** = A and **Type** = 1.

**Task 2 - Add a Material**

1. In the **Materials** tab, click ![Add New Material](Add New Material) and name it **Adobe**.

2. Select it in the list and click ![Edit Material](Edit Material).

3. In the **Display Properties** tab, check the General Medium Detail display representation. Click ![Edit Display Properties](Edit Display Properties) if it does not open automatically.
4. In the **Hatching** tab, set the hatch pattern, scale, and angle as shown below. AR-CONC is a Predefined Hatch pattern.

![Display Properties (Drawing Default) - General Medium Detail](image1)

5. In the **Other** tab, specify the Render Materials as shown below.

![Display Properties (Drawing Default) - General Medium Detail](image2)

6. Click **OK** to close the Display Properties and Material Definition Properties dialog boxes to return to the Style Manager.
Task 3 - Specify a Classification and Test the Style

1. In the Classification tab in the Style Manager, set the Structural Usage to Load Bearing.

2. Click OK to close the Style Manager.

3. Draw several walls using the new style. Hint: Start any Wall tool and change the style to Adobe in the Properties palette.

4. In plan view you should see the concrete hatch pattern.

5. Switch to a 3D view and change the visual style to Realistic so that you can see the rendering material. Zoom in so you can see the texture.

6. Save the drawing.
Self Check: General Style Information

1. How do you open the Style Manager so that it displays only one style type (such as wall styles)?

2. Where can you attach documentation to a style?

3. What are display properties?

4. If the material definitions you need are not available in a drawing, how can you access them?
Section 2: Wall Tools

In this section you will learn how to:

- Create wall modifiers.
- Change wall modifiers.
- Use wall tools to override endcaps and clean up radii, add interference conditions, merge and join walls, etc.
- Create complex wall shapes with Sweep Profile and Body Modifier.
Creating Wall Modifiers

The **Wall** command is a powerful tool in itself, but there are times when you need variations that cannot be created with default walls. You could need to add columns or chases, clean up wall intersections that are not doing what you expect, or change the way the wall functions at an opening. This section discusses a variety of tools that can help in these cases.

When there are columns, chases, and other obstructions in a wall, they can sometimes jut out into the room. Instead of trying to draw a very short wall or putting a second wall on top of another one, use **Plan Modifiers** to create the variation. These show in 3D as well as 2D but are called Plan Modifiers to differentiate them from the Body Modifiers explained later.

- Wall Modifiers are not separate AEC objects; they are considered part of the wall. Therefore, you usually need to select walls when you work with the modifiers.
- To access Wall Modifiers and most other walls tools, select a wall and right-click for the menu.
To Add a Wall Modifier

1. Select a wall.
2. Right-click and select Plan Modifiers>Add.
3. Select a start point and end point for the modifier. These points determine the length of the modifier along the wall.
4. Select a point on either side of the wall to specify which side you want the modifier on.
5. Type the wall modifier depth.
6. Fill out the Add Wall Modifier dialog box as needed.

```
Add Wall Modifier

Modifier Style:
- Standard

Wall Component:
- Stud

[ ] Offset Opposite Face

Start Elevation Offset: 0° from: Wall Bottom
End Elevation Offset: 0° from: Wall Top

OK Cancel
```

7. Click OK to draw the modifier.
## Wall Modifier Options

![Add Wall Modifier dialog box](image)

### Modifier Style
The shape of the modifier. The Standard style that comes with AutoCAD Architecture is a rectangular shape. You can add other shapes using the **Wall Modifier** style command.

### Wall Component
If you are working on a wall that has more than one type of material, select the correct component for the modifier. In the example below, the modifier on top is related to the brick component while the bottom one is related to the CMU component.

![Wall Component diagram](image)

### Offset Opposite Face
If selected, creates the same modifier on the other side of the wall.

### Start/End Elevation Offset
Modifiers can be the same height as the wall or just part of it such as the soffit of a vaulted ceiling or a gas fireplace chimney that starts above the ground. You can set the Elevation offsets from the Wall Bottom, Wall Top, Wall Base Height, or Wall Base line.
To Convert a Polyline to a Wall Modifier

For more complex modifier shapes, start with a polyline. It must be touching the wall and open rather than closed.

1. Draw the polyline. It must be open and touching the wall.
2. Select the wall.
3. Right-click and select Plan Modifiers>Convert Polyline to Wall Modifier.
4. Select the polyline.
5. Select whether or not to erase the layout geometry.
6. Type in a style name in the dialog box that appears.

7. Fill out the Add Wall Modifier dialog box. The Modifier Style option is grayed out but shows the name you just added.
8. Click OK to close the dialog box and finish the command.

Any style name you create when you convert a polyline to a wall modifier is added to the Wall Modifier Styles and is available for use when you add a wall modifier.
To Create Wall Modifier Styles

The simplest way to create wall modifier styles is to go through the process of converting a polyline to a wall modifier, but you can also create a style in the Style Manager.

1. Draw an open polyline to be the outline of the wall modifier style.
2. Start the Style Manager (Format>Style Manager…)
3. In the Style Manager, drill down through the Architectural section to the Wall Modifier Styles.
4. Click (New Style) and name the new style.
5. Make sure the new style is selected and click (Set From).
6. Select the polyline.
7. Click (OK) to close the Style Manager.

You can preview the style by selecting it and clicking (Floating Viewer) on the bottom left corner of the Style Manager.
Practice - Creating Wall Modifiers

In this practice you add wall modifiers and convert a polyline to a wall modifier to create pilasters on the wall of a chapel. You will also create a new Wall Modifier Style and use it in the same drawing. Estimated time for completion: 15 minutes.

1. Open the drawing Chapel.dwg.

2. Zoom in on the lower right corner of the building.

3. Select the bottom wall, right-click, and select Plan Modifiers>Add.

4. Create a 1'-0" x 6" modifier using the Standard modifier style between each set of windows on one side of the building, centered on the wall segment as shown below. Use (Object Snap Tracking) to select the points.

5. Add modifiers on the opposite wall. (Or erase it and then mirror the wall with modifiers to the other side.)
6. Thaw the layer **Polyline**.

7. **Zoom In** on the polyline at the bottom of the curved wall.

8. Select the wall that the polyline is touching, right-click and select **Plan Modifiers > Convert Polyline to Wall Modifier** to make this polyline into a wall modifier named “Fancy.” Make sure you select the non-curved part of the wall—the modifier does not fit on the curved wall.

9. Add the new “Fancy” Wall Modifier between each window of the apse (the curved wall). Select the first and second points where the white lines intersect with the CMU wall to get the right size. The depth should be 1’ and the component CMU.

10. Use the Style Manager to create a new Wall Modifier style called “Triple,” based on the polyline near the door.

11. Add the new “Triple” modifier to create pilasters 1’-0” away from each side of the door. The size is 3’-0” x 2’-0”.

12. Freeze the layer **Polyline**.

13. Save the drawing.
Changing Wall Modifiers

Wall modifiers are part of a wall. Therefore, you cannot erase them without erasing the wall as well. Standard AutoCAD commands such as Move and Stretch do not work on only the modifier either. To change a modifier, you must start the Edit In Place command.

Editing a Modifier In Place

Once a wall has a modifier, you see an extra option in the shortcut menu: Plan Modifiers>Edit in Place. Selecting this option enables you to change the modifier with grips or commands like Move and Stretch. The grip at the midpoint of each segment moves the entire edge. The cyan grip at the center where the modifier touches the wall moves the modifier along the wall with the help of dynamic dimensions.

When Edit In Place is active you see the In-Place Edit toolbar. This is available with many other commands, not just Wall Modifiers.

<table>
<thead>
<tr>
<th>Zoom To</th>
<th>Zooms in on the object being modified.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discard All Changes</td>
<td>Ends edit in place and does not save any changes you could have made in the process.</td>
</tr>
<tr>
<td>Save All Changes</td>
<td>Ends edit in place and saves any changes you could have made in the process.</td>
</tr>
</tbody>
</table>
While you are in **Edit In Place** there is a shortcut menu that gives you additional options.

<table>
<thead>
<tr>
<th>Add/Remove Vertex</th>
<th>Select a point to add a vertex and then move it with grips. If you are removing a vertex, click on the one you want removed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide/Show Edge</td>
<td>If for some reason you do not want an edge of a modifier showing you can turn it off using the <strong>Hide Edge</strong> command. While you are in <strong>Edit In Place</strong> the line is red. When you save and exit the line does not show. You can make it visible again with the <strong>Show Edge</strong> option.</td>
</tr>
<tr>
<td>Replace Modifier</td>
<td>You can draw an open polyline anywhere on your screen and then use the new polyline in place of the existing modifier. A new style name, using the existing name with a (2) after it, is created.</td>
</tr>
<tr>
<td>Remove Modifier</td>
<td>Removes the modifier and ends <strong>Edit In Place</strong>.</td>
</tr>
<tr>
<td>Save Changes</td>
<td>Saves the changes you have done up to this point but does not end <strong>Edit In Place</strong>. (Same as the tool button.)</td>
</tr>
<tr>
<td>Save As New Wall Modifier Style</td>
<td>Creates a new style based on the changed modifier. Select the modifier. Type a new name for the modified style.</td>
</tr>
<tr>
<td>Discard All Changes</td>
<td>Ends <strong>Edit In Place</strong> without saving changes. (Same as the tool button.)</td>
</tr>
</tbody>
</table>

You can also remove a modifier without going into **Edit In Place**. Select the wall with the modifier, right-click, and select **Plan Modifier>Remove**. You can then convert the modifier to a polyline (if you want to modify it and add it again) or you can just remove it entirely. The default is to remove it.
**Wall Properties – Plan Modifiers**

Another place to make changes to modifiers is through the Properties palette when you select a wall. A Plan Modifiers worksheet is listed at the bottom of the Advanced Options in the Worksheets section. In this worksheet you can add or remove modifiers as well as change the name and dimensions of existing modifiers.

![Wall Modifiers](image)

<table>
<thead>
<tr>
<th>Add</th>
<th>You can add a modifier using this dialog box. This tool creates a Standard style modifier. Make changes through the other options below.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove</td>
<td>Removes the selected modifiers from the wall.</td>
</tr>
<tr>
<td>Modifier Style</td>
<td>The style of the modifier.</td>
</tr>
<tr>
<td>Component Name</td>
<td>The component (for example, brick, or CMU) the modifier is attached to.</td>
</tr>
<tr>
<td>Apply To:</td>
<td>Select from Left, Right, or Both Faces of the wall.</td>
</tr>
<tr>
<td>Start Position Offset</td>
<td>This is where the modifier is located along the wall.</td>
</tr>
</tbody>
</table>
Start/End Elevation Offset

The start and end of the elevation offsets. You can change this here.

Mirror X/Y

You can have the modifier mirror around the X- or Y-axis. Sometimes this happens automatically, depending on the direction the modifier was made in the first place.

Measure to Center

Uses the Start Position Offset as the center of the modifier rather than the first point selected.

Use Drawn Size

If checked, the modifier becomes the size of the original polyline.

Length/Depth

The length and depth of the modifier. This is grayed out if "Use Drawn Size" is selected.

Practice - Changing Wall Modifiers

In this practice you edit a modifier and save the changes as a new style. You also change several existing modifiers through the wall properties. Estimated time for completion: 10 minutes.

1. Continue using the drawing Chapel.dwg.

2. Select the wall near the door, right-click, and select Plan Modifiers> Edit in Place. Click Yes if prompted to convert the modifiers.
3. Click (Zoom To) to zoom in on the modifier above the door. Select the modifier so the grips appear. Select the midpoint grip of the left edge, and move the edge 2” to the right.

4. Right-click and select Add Vertex. Select the midpoint of the same edge as the location, and press <Enter> to continue. Select the edge again. The middle grip is now a vertex. Stretch the vertex 6” to the left to create a point.

5. With the wall still selected, right-click and select Save as New Wall Modifier Style. Select the changed modifier, and name the new style Pointed.

6. Click (Save All Changes) in the In-Place Edit toolbar.

7. To change the modifier below the door to the same style, select the wall. In the Properties palette, scroll down to find the Plan Modifiers worksheet, and click the button to open the worksheet. In the list select the Triple (2) modifier and change its style to Pointed. Click OK to close the dialog box.

8. Save and close the drawing.
Miscellaneous Wall Tools

AutoCAD Architecture automates much of the work related to walls, such as cutting out and anchoring doors and windows, cleaning up intersections, and placing endcaps. Still, there are times when you need to change the default results. The following tools can help get your walls to the exact form you want.

Modifying Endcaps

Endcaps display on a wall that does not touch another wall and at wall openings such as doors and windows. You can substitute one endcap style for another, create an endcap from a polyline, and edit the endcap in place.

Endcap styles are preset in wall styles. When you draw a wall, the wall style determines the default endcaps.

- You can create new endcap styles using Wall Endcap Styles.
Overriding Wall Endcap Styles

The most common use of this wall tool is to change the existing default endcap to one that you specify. Other endcaps must be defined in your drawing to do this.

1. Select the wall, right-click, and select **Endcaps>Override Endcap Style**.
2. Select a point on the wall that is closest to the end you want to change.
3. Select an endcap style from the list and click **OK**. The **BYSTYLE** option sets the endcap style to the type set by the wall style.

Creating an Endcap from a Polyline

One way to create a new endcap is the **Calculate Automatically** option.

1. Draw a polyline that describes the endcap.
2. Select the wall where you want to apply the endcap, right-click, and select **Endcaps>Calculate Automatically**.
3. Select the polyline.
4. Select to erase or keep the polyline.
5. Select to modify the current endcap style or not.
6. If you select not to modify the current endcap style, the next prompt asks if you want to apply this new style to the wall style default or to an override. If you select the default, the endcap style is applied to all wall ends of that wall style. If you select an override, it only applies to the end you have selected.
7. Specify a new name for the endcap style.
Editing Endcaps in Place

Because endcaps are built on polylines, you can edit them in place. Be aware that this changes the default endcap style for every wall of that style in the drawing. Like other edit in place functions, you can edit using grips or standard AutoCAD commands. You also have access to the same right-click functions described earlier in Wall Modifiers as well as two additional options:

Replace Endcap  
Similar to Calculate Automatically. You select a polyline that replaces the existing endcap. The change is applied to the existing endcap style.

Remove Endcap  
Completely removes the endcap that you select.

Modifying the Roof and Floor Lines of Walls

Where walls touch roofs or floors, there can be conditions other than straight across. For example, you might have a gable roof and a slope across the side of a building as shown above. The Roof/Floor Line options help you manipulate walls at the top and bottom.
Modify Roof Line, Modify Floor Line

These two tools have essentially the same options.

<table>
<thead>
<tr>
<th>Offset</th>
<th>You can offset the roof or floor line of a wall. A positive offset moves the wall up and a negative offset moves the wall down.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project to Polyline</td>
<td>If you have a complex shape that you want the roof or floor line to follow, such as a parapet or contour, you can draw a polyline on the face of the wall and then project the wall to the polyline. You need to make sure you are in the correct UCS when you draw this polyline.</td>
</tr>
<tr>
<td>Generate Polyline</td>
<td>Once you have modified a roof or floor line you can generate a polyline from that shape. This would be one way to modify the line.</td>
</tr>
<tr>
<td>Auto Project</td>
<td>Projects the roof or floor line to other AEC objects such as roofs and slabs. This is the best way to set the gable end of a wall after you have drawn a roof.</td>
</tr>
<tr>
<td>Reset</td>
<td>Returns the wall back to its original configuration.</td>
</tr>
</tbody>
</table>

**Edit in Place (Roof/Floor Line)**

You can also edit the roof and floor line with grips through **Roof/Floor Line>Edit In Place**. The grips enable you to move edges, vertices, and the entire roof or floor line. The Base Height and Base line are marked. Dynamic Dimensions work with the corner and height vertices.

- You can use the Roof/Floor Line tools with Curtain Walls as well.
Interference Condition

Some objects that are attached to walls automatically cut the wall, such as doors and windows. Other objects, such as columns, stairs, and slabs, do not cut an overlapping wall unless you set an interference condition.

You can use interference conditions with any AEC object, such as columns or Mass Objects, as well as AutoCAD 3D solids.

To Add an Interference Condition

1. Select the wall(s) where you have interference.
2. Right-click and select **Interference Condition>Add**.
3. Select the AEC objects to add to the wall wrapping.
4. Select a “shrink wrap plan effect”: **Additive**, **Subtractive**, or **Ignore**.
5. Repeat as needed.
6. To remove an AEC object from a wall, use the **Remove** option of **Interference Condition**.

- **Additive** makes the shrink-wrap go around the outside of the object. **Subtractive** makes the shrink-wrap go to the inside of where the object touches the wall. **Ignore** leaves the shrink-wrap as it was before.

- Interference conditions do not anchor or link the object to the wall.

- You can use the Interference tools with curtain walls, slabs, roof slabs, stairs, and structural members as well.
Wall Cleanup Tools

The walls in AutoCAD Architecture are flexible. Most of the time, they connect to each other as expected. If you create an extremely complex situation, the walls may not clean up correctly. In this case, an alert appears. Roll your cursor over it to view a tool tip with the problem and several solutions, as shown below.

A variety of cleanup tools can help you fix intersections between walls, including the justification, cleanup radius, “L” and “T” cleanups, and merge conditions. These can be accessed from the right-click menu under Cleanups, as shown below, whenever a wall is selected.
Toggle Wall Justification Display

The **Toggle Wall Justification Display** tool displays the cleanup radius (shown as a circle at the wall end), as well as the justification line of each wall (shown as a blue line), as shown below. If you do not see a circle, the cleanup radius is set to 0.

![Image of wall justification display]

Modifying the Cleanup Radius

The wall cleanup radius determines how close together walls must be in order for intersections to clean up automatically. When the Wall Justification Display is on, you see additional grips that enable you to modify the cleanup radius, as shown below.

![Image of modified cleanup radius]

You can also modify the radius using the **Override Cleanup Radius** command or in the Properties palette when a wall is selected.

Editing the Justification

An additional way to control intersections is changing the justification of the wall. Select the wall, right-click and select **Edit Justification**.

![Image of edited justification]

- **Set to Right**
  - Hold CTRL while selecting to maintain baseline
The diamond-shaped grips are the various justifications you can select from. If you hold down the <Ctrl> key while selecting, the baseline does not change. The dashed line shows where the wall is located if you do not maintain the baseline.

**“L” and “T” Cleanup**

Two cleanup commands can help solve some wall cleanup issues that might not be resolved automatically. Their names describe what they do: “L” Cleanup and “T” Cleanup.

To use these commands, select a wall, right-click and select **Cleanups>Apply “L” (or “T”) Cleanup**, then select the second wall to clean up.

**Merging Walls**

Merging walls does not automatically clean up corners, but it does help unite walls that would otherwise create a wall defect warning. You can use this command in a similar way to a **Wall Modifier**.

1. Select a wall, right-click, and select **Cleanups>Add Wall Merge Condition**.
2. Select the wall(s) to merge with it and press <Enter> to finish.

- To remove wall merge conditions select the wall, right-click, and select **Cleanups>Remove All Wall Merge Conditions**.
**Reversing the Wall Start and End**

You might put in a wall with the wrong justification, or one that has the brick on the inside of a room when you wanted it on the outside. Select the wall, right-click, and select **Reverse> In Place** or **Baseline**.

- Be aware that you may have to move the wall after you reverse it because you have changed the justification if you do not use **Reverse> In Place**.
- You can reverse Curtain Walls as well.
- This option is also available with a standard grip, as shown below.

**Offsets Walls**

You can offset walls with the standard **Offset** command. The special wall **Offset** command, however, enables you to select the component from which to offset. For example, you can offset from the face of the stud instead of the gypsum wallboard, as shown above.
To Offset a Wall

1. Draw the primary wall.
2. Select the wall, right-click, and select Offset>Copy (or Move).
3. Select the component to offset from.
4. Select a point to offset to. You can also use the dynamic dimensions.
5. Continue offsetting as needed.

The Set From option of the Offset command enables you to change the distance between two existing walls by defining the component to offset from and then a point or wall component. Dynamic dimensions are then available for you to change the distance from the point or other wall. The wall you selected moves.

Joining Walls Together

Sometimes you have walls that look like they are one but are actually two or more walls. You can join them together.

- Select one wall, right-click, and select Join. Select the second wall. A note at the Command Line displays when the walls successfully are joined.

- The walls must be joined at the baseline, have the same wall style and width, and be part of the same cleanup group.

- Objects such as doors, windows, wall modifiers, and interference conditions remain linked to the joined wall.
In this practice you will modify existing walls using various wall tools. Estimated time for completion: 10 minutes.

1. Open the drawing More_Walls.dwg.

2. Zoom in on one corner of the building. The brick is on the inside of the building rather than the outside.

3. Zoom out again so that you can see the entire drawing.

4. Select all exterior walls and reverse them using the In Place option.

5. Select the horizontal interior wall. It is actually two segments. Join the walls together. Select the wall again so you see it is just one and then <Esc> to release the grips.

6. Zoom in on the interior wall at the right side that is not touching the exterior walls.

7. Use Cleanups>Toggle Wall Justification Display to see the cleanup radius and justification lines displayed on the walls.

8. Select the interior wall. Using the Cleanup radius grip, change the Cleanup Radius to 2'-0".
9. You should see a circle on the screen, and the interior wall clean ups with the exterior wall.

10. Turn the Wall Justification Display off.

11. Turn on the layer A-Cols. Zoom out so you see three columns in the drawing, two on the back wall and one on the horizontal interior wall.

12. Add the columns as an Interference Condition. Use Additive shrinkwrap. Do the interior wall separately from the exterior wall.

13. Zoom in on the door at the front of the building.

14. The brick at the end of the wall turns the corner, but because there is a frame here you do not need this effect. Use Override Endcap Style and select a point near the doorjamb. Set the style to Standard. Repeat on the other side of the door.

15. Repeat the process at the other door.

16. Turn on the layer A-Roof.

17. Switch to a 3D view where you can see the gable ends of the roof where the walls are not touching.

18. Modify the roofline to meet the gable roof, using the Auto-project option.

19. Save and close the drawing.
Complex Wall Shapes

Few walls are made up of perfectly flat faces. You could need to create corbelling under the roof edge, a sloped retaining wall, or pilasters pushing out from the wall. You can create these effects with Sweeps and Body Modifiers.

Creating a Wall Sweep

With Wall Sweeps, a profile can be swept along a wall to modify the shape. For example, you could use a profile to create the corbelling shown above. Or you could want to show a chair rail and molding on the interior of an historic building.

- To create a profile, draw a closed polyline of the desired shape. Select the polyline, right-click, and select Convert to>Profile Definition…. Select an insertion point, select to apply to a new profile, and type the new name.

- Sometimes the profile can go into the wall when you want it to go out. You can reverse the wall using grips or use the Reverse option of the wall’s shortcut menu to make it go the other way.
To Create a Wall Sweep

1. Create the desired profile.
2. Select the wall, right-click and select **Sweeps>Add…**. The Add Wall Sweep dialog box appears.

3. Select from the list of **Wall Components** if there is more than one. This assigns the profile to the component you select.
4. In the **Profile Definition** section select the profile you want to use. If you do not have an existing profile you can create a sweep from the components in the wall. Selecting **Start from scratch**… takes you into Edit In Place.
5. If you are starting from scratch, type a **New Profile Name**.
6. If Roof or Floor lines have been applied to a wall you can also apply them to sweeps.
7. You can also select to **Miter Selected Walls** if you select more than one intersecting wall at a time.
8. Check **Continue Editing** if you want to make changes to the chosen profile. When you finish the profile, Edit in Place opens.
9. Click **OK** to finish.

- You can edit or remove sweeps through the Sweeps worksheet in the Properties palette when you have selected a wall with a sweep.
To Edit Sweeps in Place

1. Select the wall with a sweep that you want to edit, right-click, and select **Sweeps>Edit Profile In Place**.
2. Select a location on the wall for editing. This can be anywhere along the wall, not just at one of the ends.
3. The In-Place Edit toolbar appears and the component with the sweep is highlighted with grips.
4. Use grips, the shortcut menu, and standard AutoCAD modification tools as needed.
5. Click (Save All Changes) in the In-Place Edit toolbar to finish.

To Clean the Corners of Swept Profiles

Un-mitered            Mitered

When you create sweeps along two walls that meet at a corner, they might not automatically clean-up using the new sweep unless you had selected both walls when you applied the sweep. Select one of the walls, right-click, and select **Sweeps>Miter**. Then select the second wall.
Using Body Modifiers

A Body Modifier is an AEC object that becomes part of the wall. This is different from the Interference Condition, which shrink-wraps around the outside or inside of the object but leaves it intact. A Body Modifier is no longer a separate object after it modifies the wall.

Body Modifiers can be additive or subtractive, or can replace a wall entirely. For example, you could create a niche in a wall with a mass element made subtractive, or a pilaster with a mass element made additive. The Replacement option enables you to convert a shape into a wall object, such as a thick column that you wanted to actually be part of the wall.

- Body modifiers can also be applied to slabs, roof slabs, stairs, and structural members.

To Add a Body Modifier to a Wall
1. Draw a mass element, other AEC object, or AutoCAD solid.
2. Select the wall, right-click, and select Body Modifiers>Add….
3. Select the objects to apply as body modifiers. The Add Body Modifier dialog box appears as shown below.
4. Select from the list of available wall style components. The modifier is assigned to this component.
5. Set the type of operation: *Additive-Cut Openings, Additive, Subtractive, or Replacement.*
6. Give the modifier a description. It is listed by this name in the Properties palette when you select the wall.
7. Select to keep or erase the layout geometry.
8. Click **OK** to finish.

- You can remove a Body Modifier using the Body Modifier worksheet in the Properties palette when you select the wall.

- The **Replacement** option changes the entire wall into the body. For example, you could want to create a concrete pillar. Draw the pillar using the **Mass Elements** command. Then draw a wall using the concrete style and replace the wall with the body. The Mass Element takes on the properties of the wall.

![Mass Element](image1.png) ![Body Modifier-Replacement](image2.png)

- For curved AEC objects (like a round pillar), the number of sides used to create the curve is controlled by the **facetdev** system variable. Use a lower number for **facetdev** to get smoother curves. This value must be set before you create the object. A low value for **Facetdev** can slow down drawing performance if you have many curved features.

- Mass Elements can also be directly created into a wall. Select the Mass Element, right-click, and select **Convert to Wall**. The object looks the same as the Body Modifier but functions differently with grips and in the Properties palette.
Practice - Complex Wall Shapes

In this practice you will create a profile and use **Sweep** to add the profile to the walls of a building. Then, you will use the **Body Modifier** command to create pillars, pilasters, and niches. Estimated time for completion: 15 minutes.

1. Open the drawing *Fancy_Facade.dwg*.

2. Draw the closed polyline shown above.

3. Select the polyline, right-click, and select **Convert to>Profile Definition**. Select the bottom left corner as the insertion point. Name the profile *Wall Edge*.

4. **Note**: The numbers shown in the diagram are for reference and do not represent actual dimensions.
4. Select the eight exterior walls (not the two short segments). Right-click and select **Sweeps>Add**. Apply the new **Wall Edge** profile to the Brick wall component. Make sure the Miter Selected Walls option is checked.

5. Switch to a 3D view and the Realistic visual style to see the new wall style.

6. Switch back to the top view and 2D Wireframe visual style.

7. Thaw the Mass Elements layer **A-Mass**.

8. Zoom in on the front of the building. Use the **Body Modifier** command with the **Additive** option and add the four corner pilasters as shown below. Select the option to **Erase Selected Objects**.

9. Use **Body Modifier>Add** with the Replace operation and replace the two short wall segments with the columns. Select the option to **Erase Selected Objects**.

10. Freeze layer **A-Mass** and thaw layer **A-Mass-Grps**.

11. Zoom out a little until you can see the mass group elements at either side of the entrance.

12. Use **Body Modifier>Add** with the Subtractive operation to remove the mass groups from the wall, creating niches. Select the option to **Erase Selected Objects**.

13. Thaw layer **A-Roof** and switch to a 3D view again to see the facade.

14. Save and close the drawing.
Self Check: Wall Tools

1. What shape is the Standard Wall Modifier Style?

2. If two walls look like they should clean up but they do not, which wall tools might help to fix the problem?

3. What is the difference between an Interference Condition and a Body Modifier?

4. What is the purpose of the Miter command?

5. How do you remove a Body Modifier, Interference Condition, or Sweep from a wall?
Section 3: Advanced Sections and Elevations

In this section you will learn how to:

- Create horizontal and vertical sections.
- Use subdivisions to control the display of section/elevation objects.
- Add and modify linework on section/elevation objects.
- Apply materials and modify material boundaries.
Horizontal and Vertical Sections

In addition to the basic elevation and section objects that you can create using the Callout tools, you can add advanced horizontal and vertical sections to your drawings. These commands, found in the Design Tool Palette, create sections of building models. They differ from the Callout tools as they use a two-step method and can create 2D or 3D section/elevation objects.

- Use the basic Callout tools for interior and exterior elevations and building sections if you are creating a 2D Section/Elevation because they are faster and require less interaction. However, if you need more control, need to regenerate the object, or want a 3D Section/Elevation, use the tools described here.

- Horizontal sections are most useful with tapered buildings. A standard floor plan view would not necessarily show the correct configuration of a sill but the horizontal section does. They are also useful to show a set of clearstory windows above the standard cut line.

- Vertical sections create the standard section objects and can also display elevations. In this case, place the cut line outside of the building.
These commands do not include titles with the section objects they create.

Creating a horizontal or vertical section is a two-part task. First you must insert a Section Line object that describes the location of the elevation or section. Then you generate the elevation or section from that object.

You can use the **Live Section** command with horizontal and vertical section lines.

**To Add a Horizontal Section**

1. Draw the building model.
2. Click the **Horizontal Section** tool in the *Design* tab of the Design Tool Palette set.
3. Select the two corners from the lower left to the upper right sides that define the extents of the horizontal section view. Choosing corners in other directions does not give you the expected results.
4. Type an **elevation** for the cut of the section plane.
5. Type the **depth** for the section below the cut plane.
6. Select the Section Line, right-click, and select **Generate 2D Section**...
The Generate Section/Elevation dialog box displays as shown below.

7. In the Result Type section select to create either a 2D or 3D Section/Elevation object. You can also specify a Section/Elevation style if one has been created in your drawing.

8. In the Selection Set section click (Select Objects). This takes you to the drawing screen. When you have finished selecting objects, press <Enter> to return to the dialog box. You can then click (Select Additional Objects) or (Reselect Objects) as needed.

9. In the Placement section click (Pick Point) to specify the point in the drawing where you want the section. You can also specify exact X, Y-, and Z-coordinates or replace an existing section object.

10. If you want a different Display Set, select that from the list.

11. Click OK to finish.
To Add a Vertical Section or Elevation

1. Draw the building model.
2. Click the **Vertical Section** tool in the **Design** tab of the Design Tool Palette set.
3. Select the start point and other points as needed. Section lines can contain multiple segments. Press <Enter> to finish selecting points.
4. Specify the length (that is, the depth behind the line to be included in the section).
5. Select the Section Line, right-click, and select **Generate Section…**

```
Reverse
L) Enable Live Section
   Generate 2D Section...
```

6. Fill out the Generate Section/Elevation dialog box as needed.
7. Click **OK** to finish and place the elevation or section.

For elevation lines, select the two points defining the length of the elevation *counter-clockwise* around the plan.
### Generate Section/Elevation Options

#### Result Type

<table>
<thead>
<tr>
<th>3D Section/Elevation Object</th>
<th>Creates a 3D object in 3D space. You need to change to a different viewpoint to see the elevation. Be aware that 3D objects take up a lot of memory. 3D sections can display non-AutoCAD Architecture objects, such as AutoCAD-based solids or surfaces.</th>
</tr>
</thead>
<tbody>
<tr>
<td>2D Section/Elevation Object</td>
<td>2D Section/Elevation objects are put in the same plane as the floor plan.</td>
</tr>
</tbody>
</table>

#### Style to Generate

There is only one style by default, *Standard*. You can create Section/Elevation styles.

#### Style for User Linework Edits if Unable to Reapply

Available only if you are updating an elevation that has additional or modified linework. Select the style to use.
Selection Set/Display Set

Selection Set
The first time you open the dialog box, a Select Objects button displays. Once you have chosen objects, Select Additional Objects and Reselect Objects display. Click the button needed to select the objects to include in the elevation.

Display Set
In the list, select the appropriate display set (normally Section_Elev). This controls which components (for example, door swing, window mullions, or wall surface materials) of each object displays. This appearance can then be further modified by rules within the Section/Elevation Style.

Placement

New Object
Select this if creating a new section or elevation. Then select a location for the new object in your drawing through the Pick Point button or by filling in the X-, Y-, and Z-coordinates.

Replace Existing
If you already have a section/elevation object in the drawing, you can replace it with a new one. Select the object to replace.

Notes
- The section lines created here are not for annotation but are an indication that you have a section object in your drawing. Their layer is NoPlot by default.
- The section object is separate and can be moved independently of the walls, doors, windows, etc., from which it is generated.
- Be careful where you place 3D elevation and section objects. They should not overlap in visual space or they show in each other’s layout viewports.
- 3D elevations and sections require considerable memory in the drawing file and slow down performance. If you need to use them, consider referencing in the various parts of the building into a drawing used only for sections and elevations.
- If you have several floors in one drawing you need to be in a 3D view to select all of the objects in the model. If you select in the plan view you only select the objects on the first floor.
Modifying Sections

Modifying the Section Line
Select the section line to modify the vertices. The square grips define the start and end of horizontal sections and the edges and vertices of vertical sections. The round grip toggles between using the model extents for the height and not using it.

If you put the vertical line in the wrong direction, select the line, right-click, and select Reverse.

You can modify some information in the Properties palette including using the model extents, setting up subdivisions and setting the component dimensions.

<table>
<thead>
<tr>
<th>Dimensions</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Use model extents…</td>
<td>Yes</td>
</tr>
<tr>
<td>Subdivisions</td>
<td>(0)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Component Dimensions</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A Side 1</td>
<td>9'-7 3/4&quot;</td>
</tr>
<tr>
<td>B Side 2</td>
<td>9'-7 3/4&quot;</td>
</tr>
<tr>
<td>C Angle 1</td>
<td>0.00</td>
</tr>
<tr>
<td>D Angle 2</td>
<td>0.00</td>
</tr>
</tbody>
</table>

Modifying the Section/Elevation Object
You can also modify the section/elevation object. Right-click on the object to open a menu with several options. Refresh updates the objects in a section/elevation object if no new objects are added. If you want to include additional objects use the Regenerate… command, which opens the Generate Section/Elevation dialog box again.

Other ways to modify Section/Elevation objects include setting up Subdivisions, Linework, and Material Boundaries.
**Surface Hatch Toggle**

In a complicated drawing with a lot of surface hatching (such as brick on walls) you may want to turn the hatching off when you do not need to see it. In the Drawing Status Bar, click the **Surface Hatch Toggle** button. This turns off the surface hatch only in the model, not in section/elevation objects.

- Surface Hatch turned off.
- Surface Hatch turned on.
Practice - Horizontal and Vertical Sections

In this practice you will create a horizontal and two vertical sections, one of which will show an elevation. Estimated time for completion: 10 minutes.

1. Start a new drawing based on the AEC Model (Imperial Stb).dwt template. Save it with the name Midrise_Sections.dwg.

2. Select Insert>DWG Reference in the Menu Bar and select the drawing Midrise_Office.dwg from your class folder. Use the method Overlay and insert it at 0,0.

3. Create a vertical section line through the building.

4. Click on the section line and modify the length or vertices as needed.

5. Generate a 2D section to the side of the model.

6. Create a vertical section in front of the building to act as an elevation. Make sure you make it long enough to include the trees. Generate the elevation to the side of the same drawing.

7. Create a horizontal section through the building at an elevation of 36'-0" and a depth of 50'-0".

8. Generate the section to the side of the drawing.

9. Save the drawing.
You can control how section/elevation objects display by adding *subdivisions* to the section line. Subdivisions specify distances from the section line. They provide a way for you to set display properties so that items farther away from the section/elevation line print with lighter lineweights.

**To Set Up Subdivisions in a Section/Elevation**

1. Draw a section/elevation line.
2. Select the line and open Properties.
3. Click on the **Subdivisions** worksheet in the Dimensions section of the Bldg Section/Elevation Mark Properties.
The Subdivisions worksheet appears.

4. To add a Subdivision, click (Add). It creates a subdivision at 10'-0" off the elevation line by default. You can continue to click (Add) and it creates additional lines at 10'-0" increments.

5. Click on the subdivision dimension to edit the subdivision.

6. Click to close the Subdivisions worksheet.

7. In the drawing you see the subdivisions with grips at each end. You can use the grips to manipulate the location of the subdivision.

8. Refresh the existing section/elevation or create the section/elevation to see the subdivision information reflected in the elevation.
The layer and color of the various subdivisions are controlled in the Display Properties of the section/elevation line or the object.

Ten subdivisions are preset in the default Section/Elevation style but only **A-Sect-Thin** and **A-Sect-Fine** are set as layers. You can modify these (for example, as shown above the layer **A-Sect-Medm** was added to Subdivision 1). There is also a layer **A-Sect-Hide** with a hidden line style.

To delete a subdivision open the Subdivisions worksheet, select the subdivision you want to remove, and click **(Remove)**.
Practice - Subdivisions

In this practice you will add subdivisions to a section line and update the section/elevation object. Estimated time for completion: 5 minutes.

1. Continue using the drawing Midrise_Sections.dwg that you created in the previous practice.

2. Select the section line that defines the front elevation view.

3. Open Properties and click in the Subdivisions section to open the Subdivisions worksheet.

4. Add two subdivisions using the default numbers and click OK.

5. In the drawing move the subdivision lines using grips so that they are directly in front of the two setbacks of the building. Press <Esc> to release the section line.

6. Select the front elevation object. Right-click and select Refresh. You should see the changes in the colors of the subdivisions.

7. Save the drawing.
At times you need to add objects to elevations that are not displayed in the model, such as the edging shown above around the windows and on the end of the walls. You may also need to modify existing lines in the elevation/section object and set them to use different display properties.

**To Merge Linework in a 2D Section/Elevation**

You can use any vector-based AutoCAD objects (such as lines and circles) to draw the linework before merging it into the elevation.

1. Draw the linework you want to add to the Section/Elevation.
2. Select the Section/Elevation, right-click and select *Linework>Merge*.
3. Select the objects to merge into the Section/Elevation.
4. In the Select Linework Component dialog box, select the Linework Component you want the objects to be on. You can also click *(Match existing linework)* and select similar linework in the drawing.

Click **OK**. The linework becomes part of the Section/Elevation object.
Once the linework is part of the section/elevation you are not able to edit it with standard AutoCAD commands. However, you can erase it using the **Linework>Edit** command.

If you modify the model and refresh the Section/Elevation object, the linework is not modified.

Linework Components that you can select from include Defining Line (using the color of layer **A-Sect**), Hidden Vectors (using a hidden linetype), Erased Vectors, Inner and Outer Shrinkwrap, and each of the Subdivisions in the drawing.

You can change the information for these layers either in the Section/Elevation style or in the individual object display. In both cases what needs to be changed is the Display Properties.

You can also create additional Linework (Display) Components.

**To Edit Linework in a 2D Section/Elevation**

You can change existing linework to reflect different display components. In the example above, several lines were changed to the outer shrinkwrap component and a few lines were added.

1. Select the Section/Elevation object you want to modify.
2. Right-click and select **Linework>Edit**.
3. Select individual objects within the Section/Elevation using standard AutoCAD methods.
4. Right-click again and select **Modify Component** to set the linework component.
5. When you are finished editing click **Save All Changes** in the In-Place Edit toolbar.
Practice - Adding and Modifying Linework

In this practice you will draw linework and merge it with an elevation object. You will also edit linework and place it on a different linework component. Estimated time for completion: 5 minutes.

1. Continue using the drawing Midrise_Sections.dwg.

2. Zoom in on the front elevation object close to the concrete wall. Draw some decorative linework below the edge of the roof as shown above.

3. Select the elevation object, right-click, and select Linework>Merge. Select the linework you just drew. When prompted for the linework component, select Subdivision 3.

4. Select the elevation object again. Right-click and select Linework>Edit. You go into In-Place Edit mode.

5. Zoom in on the tree in front of the concrete section of the building. Erase most of the interior lines leaving enough to show the outline of the tree.

6. If any objects in the tree are showing in a darker color they are probably on Subdivision 1. Select these objects, right-click, and select Modify Component.

7. In the Select Linework Component dialog box, select Subdivision 3 from the pull-down menu and click OK. The entire tree should now be the same color.

8. Click (Save All Changes) in the In-Place Edit toolbar.

9. Save the drawing.
Modifying Material Boundaries

Materials are built into many of the styles of objects in AutoCAD Architecture including walls, windows, and doors. For example, a wall with brick on one side and block on the other displays the outline of the brick or block in the model and section/elevation views. To better see the materials you can shade or render the model.

When you create section/elevation objects, the material hatching could make the drawing too busy to be understandable. In this case, you can modify the display to remove some portions of materials or to emphasize others by using material boundaries.

To Add a Material Boundary

1. Draw a closed polyline(s) around the area where you want the material boundary.
2. Select the section/elevation.
3. Right-click and select Material Boundary>Add….
4. Select the polyline.
5. Specify if you want to keep or erase the linework (polyline).
6. The 2D Section/Elevation Material Boundary dialog box appears.
7. Fill out the dialog box as needed and click OK.
8. The new material boundary displays.

■ You can apply more than one boundary on a section/elevation object. Create the first one and then, even though the hatching might not be showing, apply the next. All boundaries apply.
Material Boundary Options

Purpose: Specify if the material boundary is to **Limit** (show the material only within the boundary) or **Erase** (show the material only outside the boundary).

Apply To: Select from the list of what the material boundary is applied to: Surface and Section Hatching, Surface Hatching Only, Section Hatching Only, Edge Linework only, or All Linework.

Material Selection: Select to apply the material boundary to All Materials or to Specific Materials (select from the list below).

- **Apply to section shrinkwrap hatching**: Checking the box applies the material boundary to shrinkwrap hatching. Clearing the check leaves the shrinkwrap hatching as is. Shrinkwrap hatching is off by default as the section hatching takes precedence.

- **Apply to section shrinkwrap linework**: Checking the box applies the material boundary to shrinkwrap linework (the outer edge of the shrinkwrap). Clearing the check leaves the shrinkwrap linework as is.
Editing Material Boundaries

To edit a material boundary select the section/elevation object, right-click and select Material Boundary - Edit In Place. You can then modify the polyline using the vertex and edge grips. You can also access other options using the shortcut menu, including AEC Modify Tools, Add/Remove Vertex, Add/Remove Rings, Edit Object Display, and Edit Material Boundary, which opens the 2D Section/Elevation Material Boundary dialog box.

- When you have finished modifying the material boundary click (Save All Changes) in the In-Place Edit toolbar to finish.
To Apply Materials to Individual Components

Many object styles that come with AutoCAD Architecture already have materials applied to their components where appropriate. However, some objects (such as roofs) do not have styles. In these cases, you need to assign materials to the individual objects.

1. Right-click on the Tool Palette title bar and select Visualization.
2. Select the Materials tab in the Visualization tool palette group.
3. Select the material you want to apply.
4. Select an object. As you roll the cursor over the object, a tool tip appears detailing the material and the component of the object, as shown below.

5. Press <Enter> to apply the material to all objects using the same style, or right-click and select This Object to apply it only to the selected object.

If the material you want is not available in one of the tools (or in the Material tool in the Design tool palette), copy one of the other tools. Right-click on the new tool and select Properties. In the Tool Properties dialog box under the General category, select from the list beside Definition Name. Modify other properties as needed and click OK to finish.
Practice - Modifying Material Boundaries

In this practice you will add material boundaries to section/elevation objects. Estimated time for completion: 10 minutes.

1. Continue working on the drawing Midrise_Sections.dwg.

2. Open the drawing Midrise_Office.dwg. This is the original model that you earlier referenced into your current drawing.

3. Right-click on (Material) in the Design tool palette and select Properties.

4. In the Tool Properties dialog box under the General category, select a roof material from the list beside Definition Name and click OK.

5. Click (Material).

6. Select one of the roof objects in the model. The material is applied to the roof. This happens without prompting roofs that do not have styles.

7. Press <Enter> to start the command again and select the other roof.

8. Save and close the drawing.

9. Back in Midrise Sections you should get an alert that the Xref has been changed. Reload the Xref.

10. Select the front elevation object, right-click, and select Refresh. You should see the pattern for the roof material.

11. With all the materials displayed, the drawing has become very graphic-intensive. Create several closed polylines that define material boundaries to limit where the hatching displays in the drawing.
12. Select the elevation object, right-click and select **Material Boundary>Add**.

13. Select the first closed polyline. Delete the linework.

14. Use the defaults for the options in the Material Boundary dialog box.

15. Repeat for the other polylines you have defined.

16. Modify any of the boundaries if needed using **Material Boundary>Edit In Place**.

17. Save the drawing.
Self Check: Advanced Sections and Elevations

1. What are the two steps needed to create Vertical and Horizontal Sections?

2. What is the purpose of subdivisions?

3. How would you add detailing to an elevation that is not found on the model?

4. List the steps to remove just part of the hatching on an elevation or section object.