Introduction to 3D Modeling

The lessons covered in this chapter familiarize you with 3D modeling and how you view your designs as you create them. You also learn the coordinate system and how you can use it to help you create 3D designs.

Creating 3D models of your designs helps you to refine your ideas because you can visualize the relationship of design components. This same visualization of 3D models also helps you communicate the design idea to others. Because of the need to communicate ideas to others, every design discipline can use 3D modeling at some point in the design process.

The lessons in this chapter teach you the methods, commands, and options for creating 3D models. Methods covered include creating your designs with predefined shapes of different types, both solid and mesh.

Objectives

After completing this chapter, you will be able to:

- Explain the differences in 3D model types and how you view and display the models.
- Create solid models from primitive shapes.
- Create mesh models from primitive shapes.
- Describe the 3D coordinate system, and how to define a custom coordinate system, control the display of the coordinate system icon, and how to acquire a point in 3D space.
- Define and describe the design process.
Lesson: Introduction to 3D

This lesson introduces you to 3D modeling. It starts with an explanation of the types of 3D models you can create and how you can change your viewing direction in 3D space to look at your designs from different directions. It then explains a few of the commands that you can use to change your viewing direction, change the representation display of your models, and change the number of viewports and associated displays within the drawing area.

The reason you create a design is to validate a concept and to communicate it to others. By creating your design as a 3D model, you are able to do both of these with a lot more clarity.

In the following illustration, the drawing window is split into four equal viewports so the building and site can be viewed in different directions. Each of the views is also set up to display the geometry slightly differently based on the designer's needs.

Objectives

After completing this lesson, you will be able to:

- Describe the types of 3D models and their benefits.
- Explain the different ways you can view 3D models.
- Change the display of the models by changing the active visual style.
- Describe the ViewCube and its options.
- Activate and use the ViewCube to navigate in a 3D environment.
- View your model using Constrained Orbit.
- Set and adjust model space viewports.
Types of 3D Models

In this section of the lesson, you learn about the different types of 3D models you can create to represent your designs. While learning the differences between the types of models you can create, you will also learn the benefits of 3D modeling. With the ability to identify the types of models and their benefits, you will be able to select the proper model type to create based on your criteria and design requirements.

In the following illustration, the same floor plan is shown as a wireframe, a surface, and a solid model.

Definition of 3D Model Types

A primary benefit of 3D is the ability to visualize the design. By creating a 3D model, you can actually see how the different aspects come together. You can then use the 3D model to do a more effective job of communicating your design to others, not just those with the ability to read 2D blueprints. As well as seeing the design better, you can extract measurements from your design. Depending on the model type, those measurements can include distance, area, volume, and other mass properties. With solid models you can also check to see if other solid models, or components, interfere with each other. Once you have the model created, you can also generate 2D drawing views for documentation purposes.

The extent of the benefits of a 3D model depends on which of the four model types you created. Those four modeling types are as follows:

- **Wireframe Model** - The most basic form for 3D model representation. You draw lines, arcs, and circles in 3D space to represent the edges of your design. Though this model type can be useful, it is often difficult to work with when creating a complex model with numerous edges. When viewing a wireframe model, you see all of the edges of the model regardless of which side of the model you are viewing from.

- **Mesh Model** - Mesh models approximate a smooth surface using a mesh of faces called subdivisions. The more subdivisions there are, the smoother the surface appears. Tessellation lines represent the visual boundaries of each subdivision. Each subdivision has one face, no less than three and no more than four edges, and a corresponding number of vertices. Each subdivision face, edge, or vertex can be edited independently by moving, rotating, or scaling it with the 3D-Gizmo. The black lines on the model are called tessellation lines and visually represent the boundaries of each subdivision.

- **Surface Model** - A higher level of model representation, because it not only defines the edges of the design as in a wireframe model, but it also defines the outer skin or surface for the model. Surface models can add clarity to the display of a design by hiding all geometry that resides behind a surface. While a surface model can return values for its surface area, it cannot return mass property information because a surface has no true thickness, just a length and a width.

- **Solid Model** - This model type defines the inner volume, outer surface, and edges of your design all within a single object. Solid models represent all aspects of a design, and thus are the most complete representational type of 3D model. You can create solid models from predefined shapes or from complex outlines. You can combine solid models together to create even more complex models.
Example of 3D Model Types

While you can create your designs as wireframe models, you will find solids, and sometimes surface models, more useful to design with. If you need to model how the contour of land changes in an area, creating a surface model from contour lines at the various elevations is the most productive model creation method. You may also find creating surface models more practical if you are creating very thin-walled products like plastic bottles or the clear plastic packaging formed to hold merchandise. For all other designs such as buildings, bridges, desks, and mechanical parts, solid models offer you the most versatility in creating, editing, and displaying your design.

In the following image, a 3D model of a new idea for material handling equipment was created to better discuss the design's merits and issues.

Navigating and Displaying 3D Models

As you create 3D models, it is important to view the model from different directions. Your ability to effectively change the display of your model and the direction from which you view it has a direct impact on your ability to efficiently create and complete your design. In this next section, you learn about the different ways you can change the direction from which you view your model, and other ways you can have it displayed.

In the following illustration, the same design is being viewed from three different directions. With each view, you are able to get a better understanding of the design.
Navigation and Display Defined

When working in 3D, you typically need to look at different sides of your design. To view the different sides, you do not reorient the model in 3D space. Instead, you change your viewing position in 3D space by selecting one of the predefined viewing directions on the ViewCube or by orbiting the model using other navigation tools, such as Constrained Orbit, Free Orbit, or the Steering Wheel.

Preset Viewing Directions

The preset viewing directions include top, bottom, front, back, left, right, and four additional isometric views. These preset viewing directions are based on the default alignment of the X, Y, and Z coordinate system. For example, the top view looks straight down the Z axis at the X, Y plane, while the front view looks in the direction of the Y axis at the X, Z plane. Use the ViewCube to quickly change from one viewing direction to another or to establish a start point from which you can orbit to the exact required viewing direction.

Orbiting Your View

When orbiting your view, the pivot point is the center of a bounding box around the geometry. This bounding box is a mathematical box that is just large enough to encompass either all of the geometry in your drawing or just the geometry you select. You can use the ViewCube or Orbit command to reorient your display by orbiting around the 3D model.

Display Types

As you add more detail to your modeled design, your ability to understand what you are looking at, with respect to your model, depends more on how you display the model. There are three main ways of displaying a surface, mesh, or solid model. You can have it display as a wireframe, where only the edges are displayed, but you can see all the edges as if it were a wireframe model. You can have it display in hidden mode, where all edges are displayed except the ones that cannot be seen based on the current viewing direction. Or, you can display it in a shaded form, thereby only showing the visible faces and edges of the model based on its current viewing direction. Each of these display modes have slight variations that change the quality or characteristics of the model that is displayed. By selecting a visual style, you activate one of these uniquely saved display modes to have your model display in that fashion.
Example of Navigating and Displaying 3D Models

In the following illustration, the model showing a newly proposed material handling equipment cart has been orbited in a way to help communicate the design. It is also being displayed in a conceptual mode to give it the appearance of a hand-sketched design that has been colored in. This type of display can then be used within a presentation to give it a different type of look and feel.

Changing the Model Display

When selecting a display mode for your 3D surface or solid model, you have five preset display modes that you can select from. These preset display modes are referred to as visual styles. The five preset display modes are:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔄</td>
<td>2D Wireframe</td>
</tr>
<tr>
<td>🔌</td>
<td>3D Wireframe</td>
</tr>
<tr>
<td>🔓</td>
<td>3D Hidden</td>
</tr>
<tr>
<td>🎨</td>
<td>Conceptual</td>
</tr>
<tr>
<td>🎯</td>
<td>Realistic</td>
</tr>
</tbody>
</table>
In the following illustration, the same model is being displayed in four different visual styles: Wireframe, Hidden, Realistic, and Conceptual. The top left, Wireframe, is useful when you want to view geometry through the model and the lower right, Conceptual, is useful when you want to present an idea as one in progress.
Command Access

Visual Styles

Command Line: VSCURRENT, VS
Ribbon: Home Tab > View panel > 2D Wireframe, 3D Wireframe, 3D Hidden, Realistic, or Conceptual

The following icons are associated with the menu and toolbars for the different visual styles.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="2D Wireframe icon" /></td>
<td>2D Wireframe</td>
</tr>
<tr>
<td><img src="image" alt="3D Wireframe icon" /></td>
<td>3D Wireframe</td>
</tr>
<tr>
<td><img src="image" alt="3D Hidden icon" /></td>
<td>3D Hidden</td>
</tr>
<tr>
<td><img src="image" alt="Conceptual icon" /></td>
<td>Conceptual</td>
</tr>
</tbody>
</table>
Accessing Visual Styles on the Ribbon

To access the visual styles on the Visual Styles panel, click the down arrow to the right of the active style name. The list of visual styles appears as preview images with text as shown in the following illustration.

Switching to a Wireframe display can make the selection process quicker if you are trying to select edges and corners that are on different sides of a model.

About the ViewCube

The ViewCube is an interactive navigation tool, an easy way to change your view orientation of a 3D model. You can quickly change between standard or isometric views. The ViewCube is available when your drawing is set to any 3D visual style, such as 3D Hidden, Conceptual, and Realistic visual styles. The ViewCube will not appear when a 2D visual style is active, such as 2D Wireframe.

The benefit of using the ViewCube is that it helps you keep track of your orientation in the drawing by displaying the current view orientation on the ViewCube tool. Understanding how the ViewCube provides feedback to you and how to adjust the display options will help you to proficiently navigate around views of a 3D model.

Description of ViewCube

The ViewCube is an interactive way to change the view in a 3D model. You can intuitively view any of the standard or isometric views of your model from the ViewCube.

The ViewCube is displayed in one of two states: inactive and active. When you first select a 3D visual style, the ViewCube is displayed as inactive in the top right corner of the drawing area by default. When you move your cursor over the ViewCube, it becomes active with hot spots that highlight as you pass your cursor over different parts of the cube. To switch views, you click on a hotspot to restore the associated view. The ViewCube then aligns itself to show the new orientation.

You can also switch between views in your drawing using the compass ring at the base of the
ViewCube. The compass ring displays North based upon what has been defined for the drawing WCS. Hence, when you click the N on the compass, the model view will switch to what has been defined as the North view of the model.

In addition to the predefined viewpoints, you can click and drag the cursor on the cube to orbit the model freely.

**ViewCube Options**

When the Viewcube is active, the following options are available:

1. **Home**: Activates the view that is set as the Home view. You can set the current view to the Home view from the ViewCube shortcut menu.
2. **Hotspot**: Highlights when you move your cursor over edges, corners or sides. Click on the hotspot to activate the corresponding view in the drawing.
3. **Coordinate System**: Specify the coordinate system (UCS or WCS). You can also create a new UCS from this pull-down menu.
4. **Compass**: Displays the North, East, South, and West directions as defined in the drawing. You can click and drag along the compass to rotate the view. You can turn the compass off in the ViewCube settings.
5. **Rotate**: Rotates the current view 90° in the selected direction: counterclockwise or clockwise. This option is not available in isometric views.
6. **Current View**: Displays in a darker gray color to indicate this is the current view in the drawing.
Example of ViewCube

The following images of a 3D house model show the changes as you select specific hot spots on the ViewCube.

Using the ViewCube

The ViewCube must first be enabled, and the view must be in a 3D visual style for the ViewCube to display in the drawing. You can then control the display and behavior of the ViewCube using the View Cube Settings dialog box, which you access by right-clicking the ViewCube. You can also specify the default location, size, and opacity of the cube.

Command Access

ViewCube Display

Command Line: CUBE; NAVVCUBE
Ribbon: View tab > Views panel > ViewCube
ViewCube Display

ViewCube Shortcut Menu
You can right-click anywhere on the ViewCube to use the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Activates the view that is set as the home view.</td>
</tr>
<tr>
<td>Parallel</td>
<td>Displays the current view using parallel projection. This type of view shows a 3D view as if a hypothetical camera point and target point are in the same position. This will usually show a flat view.</td>
</tr>
<tr>
<td>Perspective</td>
<td>Displays the current view using perspective projection. This type of view shows a 3D view as if a hypothetical camera point and a target point have a distance between them. This creates a more realistic view.</td>
</tr>
<tr>
<td>Perspective with Ortho Faces</td>
<td>Automatically displays the current view using perspective or parallel projection depending on the view. When the current view is an isometric view, the view is displayed using perspective projection. When the current view is a face view, such as top, left, or front, the view is displayed using parallel projection.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Set Current View as Home</td>
<td>Sets the current view as the Home view.</td>
</tr>
<tr>
<td>ViewCube Settings</td>
<td>Activates the ViewCube settings dialog box where you can control the visibility and display properties of the ViewCube.</td>
</tr>
<tr>
<td>Help</td>
<td>Activates AutoCAD® Help for ViewCube.</td>
</tr>
</tbody>
</table>

**ViewCube Settings**

In the ViewCube Settings dialog box, the preview thumbnail displays a real-time preview of the ViewCube as you specify the following settings.
### Option Table

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>On-screen Position</td>
<td>Specifies which corner of the viewport the ViewCube should be displayed in. The ViewCube can be positioned in any of the four corners of the drawing.</td>
</tr>
<tr>
<td>ViewCube Size</td>
<td>Controls the display size of the ViewCube.</td>
</tr>
<tr>
<td>Inactive Opacity</td>
<td>Determines the opacity level of the ViewCube when it is inactive.</td>
</tr>
<tr>
<td>Show UCS Menu</td>
<td>Controls the display of the UCS drop-down menu below the ViewCube.</td>
</tr>
<tr>
<td>Snap to Closest View</td>
<td>Specifies if the current view is adjusted to the closest preset view when changing the view by dragging the ViewCube.</td>
</tr>
<tr>
<td>Zoom to Extents After View Change</td>
<td>Specifies if the model is forced to fit the current viewport after a view change.</td>
</tr>
<tr>
<td>Use View Transitions When Switching Views</td>
<td>Controls the use of smooth view transitions when switching between views.</td>
</tr>
<tr>
<td>Orient ViewCube to Current UCS</td>
<td>Orientates the ViewCube based on the current UCS or WCS of the model.</td>
</tr>
<tr>
<td>Keep Scene Upright</td>
<td>Specifies whether the viewpoint of the model can be turned upside down or not.</td>
</tr>
<tr>
<td>Show Compass Below the ViewCube</td>
<td>Controls whether the compass is displayed below the ViewCube. The North direction indicated on the compass is the value defined by the NORTHDIRECTION system variable.</td>
</tr>
<tr>
<td>Restore Defaults</td>
<td>Applies the default settings for the ViewCube.</td>
</tr>
</tbody>
</table>

### Procedure: Activating the ViewCube

The following steps give an overview of how to activate the ViewCube.
1. Activate the 3D Modeling workspace.
2. Select a 3D visual style.
3. On the ribbon, click View tab > View panel > ViewCube to turn it on.

### Procedure: Using the ViewCube to Change Views

The following steps give an overview of how to navigate a 3D workspace using the ViewCube.
1. To change to a specific view, on the ViewCube, select the desired hotspot.
2. To rotate the view, on the ViewCube, click and drag in the desired direction.
3. To activate the home view, click the Home icon above the ViewCube.
Procedure: Changing ViewCube Settings

The following steps give an overview of how to change ViewCube settings.

1. Right-click on the ViewCube. Click ViewCube Settings.
2. Specify the desired settings.
3. Click OK.
4. To set the current view as the home view, navigate to the desired view.
5. Right-click and click Set Current View as Home.

Orbiting Your 3D Model

Orbiting your viewing point around your model allows you to see different aspects and details of your design. With the Constrained Orbit command, you can freely rotate your view around your model. If no geometry is selected at the start of the command, then the command pivots the view about the center point of a bounding box of all the geometry. If you select geometry before executing the command, then the view orbits around the center of the selected geometry.

Not only can you use constrained orbit to view your model, you can also use it while you are in another command. This means you can start creating or modifying geometry looking at the model in one direction, orbit to another relevant side, and complete the command.

In the following illustration, the creation of another model was initiated while looking at the design from one direction. The view was then orbited while still in the process of creating the new model so another point could be snapped to. The design after the creation of this additional model is then shown on the far right.
Command Access

Constrained Orbit

Command Line: 3DORBIT
Ribbon: View tab > Navigate panel > Constrained Orbit
Menu Bar: View > Orbit > Constrained Orbit
Toolbar: 3D Navigation
Toolbar: Orbit
Keyboard: Hold down SHIFT + Mouse scroll button to orbit current object

For Constrained Orbit to orbit around a selected object, the option Enable Orbit Auto Target must be selected. So if you selected a model prior to starting the constrained orbit, and your orbit does not orbit around the center of the model, then right-click and select Enable Orbit Auto Target from the shortcut menu.

Procedure: Viewing Models in a Constrained Orbit

The following steps give an overview of viewing 3D models in a constrained orbit.

1. Start the Constrained Orbit command.

2. Change the view orientation by left-clicking in the drawing area and dragging. Release the cursor to set the view direction.

3. Continue to rotate the view until you achieve the required orientation.

4. Exit the Constrained Orbit command by pressing ESC or right-clicking and selecting exit.
Procedure: Using a Constrained Orbit About a Specific Object

The following steps give an overview of viewing 3D models in a constrained orbit based on the selection of specific objects.

1. Select one or more objects.

2. Start the Constrained Orbit command.

3. Change the view orientation by left-clicking in the drawing area and dragging. Release the cursor to set the view direction.

4. Continue to rotate the view until you achieve the required orientation.

5. If the orbit does not center on the bounding box of the objects selected, right-click and select Enable Orbit Auto Target.

6. Exit the Constrained Orbit command by pressing ESC or right-clicking and selecting exit.

Setting Viewport Display

In this section of the lesson, you learn how to access the Viewports dialog box, the options for creating and configuring multiple viewports, and the overall procedure to change viewport display. When working in 3D, you can increase your productivity by changing the number of viewports displayed within the drawing area. By creating the appropriate number of viewports in the right viewing directions for the task at hand, you can view the model from multiple directions at the same time. You can also start a command in one viewport, then click into another viewport and complete the command.

Multiple Viewport Display

In the following illustration, the same drawing window is shown as a single viewport and then split into three viewports. In the multiple viewport display on the right, notice how each viewport is set to display a different direction of view. Also notice how the model is displayed in different visual styles in each of the viewports. In this case, two of the viewports display the models using the Realistic visual style and the other one uses 2D Wireframe.
Command Access

Viewports

Command Line: VIEWPORTS, VPORTS
Ribbon: View tab > Viewports panel > Named

Menu Bar: View > Viewports > New Viewports

Viewports Dialog Box

Following the typical workflow, you first display the Viewports dialog box, and then configure the number of viewports to display, the view orientation, and the display style. You start the configuration process by selecting an existing viewport configuration from the list. You then activate one of the viewports and change its view direction and visual style.

If you make a number of changes, enter a name so that when you click OK, this viewport configuration is added to the list of named viewports. To apply a saved viewport configuration, click the Named Viewports tab, double-click a configuration name, and click OK.
A list of viewport configurations you select from.

1. Use to preview the viewport configuration that will be applied after you click OK. Also use to activate a viewport for further configuration by clicking within the rectangular area of that viewport. The active viewport is shown with a square drawn just inside its borders.
2. Use to have the viewport configuration applied to the active viewport instead of the default option of Display, which changes the entire drawing window.
3. Use to have the view direction in the viewports change to common viewing directions.
4. Use to select a different preset view for the active preview viewport.
5. Use to set the visual style for the active preview viewport.
6. Use if you have changed settings from the standard configuration. Entering a unique name and clicking OK saves the viewport configuration as a named viewport.
Procedure: Changing Viewport Display

The following steps give an overview of setting the viewports display.

1. Start the Viewports command.
2. Configure the number of viewports to display.
3. Individually activate each viewport and change the view direction and visual style.
4. Name the viewport configuration.
5. Save the viewport configuration.
Exercise: Use ViewCube to Navigate a 3D Environment

In this exercise you open a drawing that contains a 3D model. You activate the 3D Modeling workspace, switch to a 3D visual style, and use the ViewCube to view the 3D model from different angles in the drawing.

3. On the ribbon, click the Home tab > View panel, and select 3D Hidden from the Visual Styles list.

4. On the ribbon, click View tab > Views panel and make sure the Viewcube is on.

The inactive ViewCube appears in the upper-right corner of the drawing.

Use the ViewCube

1. Open c_viewcube.dwg.
2. On the status bar, click Workspace Switching. Click 3D Modeling.
5. Move the cursor over the ViewCube.

6. On the ViewCube, click the southeast corner as shown.

The model and ViewCube are rotated to the southeast isometric view.

7. Right-click the ViewCube, and click Set Current View as Home.

8. On the ViewCube, click Top.

9. On the ViewCube, click the arrow as shown.

The view is rotated 90° in the counterclockwise direction.
10. On the ViewCube, click the W.

The left view is activated.

11. On the ViewCube, click the arrow on the right side of the cube as shown.

The front view is activated.

12. On the ViewCube, click the hot spot as shown.

The view displays directly in the cubicle.
13. Click the home icon. The home view displays.

14. On the ViewCube, click and drag the S around the cube. Notice the rotation of the view.
15. On the ViewCube, click and drag the cube. Move around the cube and notice the view is orbited.

Change ViewCube Settings
1. Right-click on the ViewCube. Click ViewCube Settings.
2. In the ViewCube Settings dialog box, under Display, do the following:
   - Select Top Left from the On-screen Position list.
   - Uncheck the Automatic box.
   - Move the ViewCube size slider to the Large position.

3. Clear Show Compass Below the ViewCube. Click OK. The larger, inactive ViewCube is displayed in the top-left corner of the drawing screen without the compass.

4. Close all files. Do not save.
Exercise: Interact with 3D Models

In this exercise, you interact with different types of existing 3D models by changing their display and viewing the results of these display changes.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or onscreen in the exercise. In the onscreen list of chapters and exercises, click Chapter 1: Introduction to 3D Modeling. Click Exercise: Interact with 3D Models.

1. Open M_Introduction-to-3D.dwg.

2. View the models from different orientations, as follows:
   - On the View tab, click Navigate panel > Orbit.

3. Left-click and hold, as follows:
   - Drag the cursor left and right.
   - Drag the cursor up and down.

4. Orbit until the back of the pump housings are visible.

5. Press ESC to exit Constrained Orbit.

6. Change the visual style of the drawing, as follows:
   - On the Home tab, View panel, select 3D Hidden from the Visual Styles list.

1. Wireframe model
2. Surface model
3. Solid model
7. On the Home tab, View panel, select 3D Wireframe from the Visual Styles list.


10. Use the Constrained Orbit command to rotate the view with regards to specific objects, as follows:
    - Window-select the solid and surface models.

11. On the View tab, click Navigate panel > Orbit.

12. Rotate the view until the front of the housings are displayed. Press ESC to exit the constrained orbit.

13. Close all files. Do not save.

Notice that the wireframe model is not displayed during the orbit.
Lesson: Creating Solid Primitives

This lesson describes how to create 3D designs by creating solid model primitives.

3D solid modeling is used across multiple design disciplines. Using solid model primitives is a key to creating your designs. You can use solid model primitives individually or in conjunction with other solid models to create complex designs. 3D solid models help improve visualization, which improves communication and development of the design. Additionally, 3D solid modeling helps to reduce errors and decrease the time required to complete a project.

In the following image, solid primitives are used to define space in a floor plan. A combination of cylinders, boxes, pyramids, and a torus were used to quickly create the solids.

Objectives

After completing this lesson, you will be able to:

- Define and identify solid primitives and their importance in creating 3D designs.
- Use and create solid box primitives.
- Use and create solid sphere primitives.
- Use and create solid cylinder primitives.
- Use and create solid cone primitives.
- Use and create solid wedge primitives.
- Use and create solid torus primitives.
- Use and create solid pyramid primitives.
About Solid Primitives

Using solid primitives provides you with a method for creating a range of designs from quick and basic, to complex and detailed. Utilizing solid primitives can help you finish designs quicker by enabling you to easily define and layout your design.

In the following image, the solid models help you quickly visualize the conceptual layout for a project to design tooling to create stamped parts.

Definition of Solid Model Primitives

Primitive solid models are predefined geometric shapes provided to you. You have seven basic primitive solids you can design with: a box, sphere, cylinder, cone, wedge, torus, and pyramid.

To create these shapes, you only need to supply a creation location and actual size. Once you have created a solid primitive, its information, such as volume and mass properties, is available to you. When you have created more than one solid primitive, you can create a more complex model by combining primitives into a single model. You can also subtract the volume of one model from another.

For many design needs, you can create and position solid primitives together much as you may have done with wooden building blocks when you were a child.
Example: Solid Primitives Used for Fixtures and Furniture

You can use solid primitives to represent all types of objects including mechanical parts, machines, buildings, fixtures, and furniture. In the following image, a basic floor lamp has been created using only primitive solids. This model can now be used in a room space or layout plan to help visualize placement and remaining available space.

Creating a Solid Box

You use the Box command to create rectangular or cube-shaped solid primitives. Since a box is a basic building block object, it is an important shape to work with. To create boxes efficiently, you can access the Box command and use the appropriate creation options based on your design criteria.

The following image displays two solid primitives, which are partially transparent, in order to see initial creation through a starting plane, or creation point.
Command Access

Box

Command Line: BOX
Ribbon: Home tab > Modeling panel > Box
Menu Bar: Draw > Modeling > Box
Toolbar: Modeling

Options for Creating a Solid Box

Following the command prompts and a typical workflow, you begin defining the base rectangular shape by specifying two opposite corners, just like drawing a 2D rectangle. With the base shape defined, you then specify the height.

Instead of creating a box based on its default prompts and options, you can select different suboptions to create the box based on other design criteria.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center</td>
<td>Use to define the location of the solid primitive's geometric center prior to specifying its size.</td>
</tr>
<tr>
<td>Cube</td>
<td>Use to create a box with all of its edges equal to a single specified value instead of specifying three separate values for length, width, and height. You can also place the cube with its edges not parallel to the X and Y axes of the current UCS.</td>
</tr>
<tr>
<td>Length</td>
<td>Use this option to create the base rectangular shape so its edges are not parallel to the X and Y axes of the current UCS.</td>
</tr>
<tr>
<td>2Point</td>
<td>Use this option to define the height of the box by selecting 2 points.</td>
</tr>
</tbody>
</table>
Procedure: Creating a 3D Box

The following steps give an overview of creating a solid box.

1. Start the Box command.

2. Specify the base rectangular shape’s start position, orientation, and size. Do this by specifying one corner and then the other corner, or the center point and corner.

3. Specify the height.

Creating a Solid Sphere

You use the Sphere command to create a solid circular primitive. A ball bearing is an example of a sphere.

In the following image, the solid primitive is being displayed partially transparent so you can see its initial creation starting plane.

Command Access

Sphere

Command Line: SPHERE
Ribbon: Home tab > Modeling panel > Sphere
Menu Bar: Draw > Modeling > Sphere
Toolbar: Modeling
Options for Creating a Solid Sphere

When creating a solid sphere, you define the position and size of the circular cross section through its center. Creating this circular cross section is very similar to creating a 2D circle. When you start the command, you are prompted to specify the center of the sphere, then size it with a radius or diameter value.

Instead of creating a sphere based on its default prompts and options, you can select different suboptions to create the sphere based on other design criteria.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3P</td>
<td>Use to define the size of the circular cross section by specifying three points that reside in the same coordinate system plane or are located anywhere in space.</td>
</tr>
<tr>
<td>2P</td>
<td>Use to define the size of the circular cross section by specifying two points in space. When you specify these points, you supply the location and diameter of the sphere, even without knowing the location of its center point.</td>
</tr>
<tr>
<td>Ttr</td>
<td>Use when you need the circular cross section to be tangent to two different objects and a specific radius.</td>
</tr>
</tbody>
</table>

Procedure: Creating a 3D Sphere

The following steps give an overview of creating a spherical solid.
1. Start the Sphere command.
2. Specify the center point of the sphere.
3. Specify the radius or diameter.

Creating a Solid Cylinder

You use the Cylinder command to create a cylindrical solid primitive with a circular or elliptical cross section.

The following image shows a cylindrical solid primitive which is partially transparent in order to see its initial creation starting plane.
Lesson: Creating Solid Primitives

Command Access

Cylinder

Command Line: CYLINDER
Ribbon: Home tab > Modeling panel > Cylinder
Menu Bar: Draw > Modeling > Cylinder
Toolbar: Modeling

Options for Creating Solid Cylinder Primitives

Through following the command prompts and a typical workflow, you begin defining the base circular shape by specifying the center point and radius or diameter, just like drawing a 2D circle. With the base shape defined, you then specify the height. The default direction of height is perpendicular to the base circular shape.

Instead of creating a cylinder based on its default prompts and options, you can select different suboptions to create the cylinder based on other design criteria.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3P</td>
<td>Use to define the base circular shape by having its circular edge pass through three points in space. Especially useful when positioning and sizing a cylinder based on existing 3D geometry.</td>
</tr>
<tr>
<td>2P</td>
<td>Use to define the diameter of the circular base using two opposite points on its outer edge. Especially useful when you do not know the location of the center point or you are positioning and sizing a cylinder based on existing 3D geometry.</td>
</tr>
<tr>
<td>Ttr</td>
<td>Use when you need the circular base to be tangent to two different edges and a specific radius.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Elliptical</td>
<td>Use when you want the base shape of the cylinder to be an ellipse instead of a circle.</td>
</tr>
<tr>
<td>Axis Endpoint</td>
<td>Use to specify the top center point of the cylinder. This sets the cylinder height and reorients the cylinder so its center axis extends from its base center point to the selected axis endpoint, in effect, rotating the cylinder to this new alignment.</td>
</tr>
</tbody>
</table>

Procedure: Creating a 3D Cylinder

The following steps give an overview of creating a cylindrical solid.

1. Start the Cylinder command.
2. Specify the base circular shape's start position, orientation, and size. Do this by specifying the center point and then the radius or diameter. Or select one of the suboptions and respond to its requirements.
3. Specify the height or change its orientation using Axis Endpoint.

Creating a Solid Cone

You use the Cone command to create a triangular shaped primitive with curved sides that transitions the shape from the base to the top. The default base shape is circular but you can also create an elliptical base. The cone then transitions from its base size to a point at the top, or to a size smaller or larger than its base.

The following image shows cone shaped solid primitives.

Command Access

Command Line: CONE  
Ribbon: Home tab > Modeling panel > Cone
Lesson: Creating Solid Primitives

Cone

Menu Bar: Draw > Modeling > Cone
Toolbar: Modeling

Options for Creating Solid Cones

Through following the command prompts and a typical workflow, you begin defining the base circular shape by specifying the center point and radius or diameter, just like drawing a 2D circle. With the base shape defined, you then specify the height. The default direction of height is perpendicular to the base circular shape.

Instead of creating a cone based on its default prompts and options, you can select different suboptions to create the cone, based on other design criteria. Except for the Top Radius option, the suboptions are identical to the options for creating the cylinder primitive.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3P</td>
<td>Use to define the base circular shape by having its circular edge pass through three points in space. Especially useful when positioning and sizing a cone based on existing 3D geometry.</td>
</tr>
<tr>
<td>2P</td>
<td>Use to define the diameter of the circular base using two opposite points on its outer edge. Especially useful when you do not know the location of the center point or you are positioning and sizing a cone based on existing 3D geometry.</td>
</tr>
<tr>
<td>Ttr</td>
<td>Use when you need the circular base to be tangent to two different edges and a specific radius.</td>
</tr>
<tr>
<td>Elliptical</td>
<td>Use when you want the base shape of the cone to be an ellipse instead of a circle.</td>
</tr>
<tr>
<td>2Point</td>
<td>Use this option to define the height of the cone between two specified points.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Axis Endpoint</td>
<td>Use to specify the top center point of the cone. This sets the cone height and reorients the cone so its center axis extends from its base center point to the selected axis endpoint, in effect, rotating the cone to this new alignment.</td>
</tr>
<tr>
<td>Top Radius</td>
<td>Use when you want a cone shape with a flat top instead of one that comes to a point. With a smaller radius value than the base, your cone will taper in as it transitions from the base to the top. With a larger value, you create a cone that tapers out from the base to the top.</td>
</tr>
</tbody>
</table>

**Procedure: Creating a 3D Cone**

The following steps give an overview of creating a conical solid.

1. Start the Cone command.
2. Specify the base circular shape's start position, orientation, and size. Do this by specifying the center point and then the radius or diameter. Or select one of the suboptions and respond to its requirements.
3. Specify the height to create a 3D cone with a point, or select the Top Radius option.
4. If you selected the Top Radius option, specify the value for the top radius.
5. Specify the height to the flat top of the cone.

**Creating a Solid Wedge**

You use the Wedge command to create a solid triangular primitive with three rectangular faces. When you create a wedge, you end up with a shape that appears to be half of a box primitive that is split diagonally from one edge to another. The high side of the wedge is the side opposite the second point specified when creating the base rectangular shape.

In the following image, the solid primitive is being displayed partially transparent so you can see its initial creation starting plane. The base rectangular shape was created from point 1 to point 2.
Command Access

Wedge

Command Line: WEDGE
Ribbon: Home tab > Modeling panel > Wedge
Menu Bar: Draw > Modeling > Wedge
Toolbar: Modeling

Options for Creating Solid Wedge

The workflow and options for creating a wedge are the same as for creating a box primitive. Following the command prompts and a typical workflow, you begin defining the base rectangular shape by specifying two opposite corners, just like drawing a 2D rectangle. With the base shape defined, you then specify the height.

Instead of creating a wedge based on its default prompts and options, you can select different suboptions to create the box based on other design criteria.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center</td>
<td>Use this option to define the location of the solid primitive's geometric center prior to specifying its size.</td>
</tr>
<tr>
<td>Cube</td>
<td>Use this option to create a wedge with all of its edges equal to a single specified value instead of specifying three separate values for length, width, and height. You can also place the cube with its edges not parallel to the X and Y axes of the current UCS.</td>
</tr>
<tr>
<td>Length</td>
<td>Use this option to create the base rectangular shape so its edges are not parallel to the X and Y axes of the current UCS.</td>
</tr>
<tr>
<td>2Point</td>
<td>Use this option to set the height of the wedge by picking two points.</td>
</tr>
</tbody>
</table>

Procedure: Creating a 3D Wedge

The following steps give an overview of creating a solid wedge.

1. Start the Wedge command.
2. Specify the start position (1), orientation, and size (2) of the rectangular base. Specify one corner and then the other corner, or specify the center point and a corner.

3. Specify the height.

Creating a Solid Torus

You use the Torus command to create a circular tube primitive with its final shape resembling a doughnut or bicycle inner tube. You create a torus by defining the size and position of two circular shapes.

In the following image, the solid primitive on the left is shown partially transparent so you can see a representation of the defining sizes and planes for this primitive. The actual torus will appear like the image on the right.

Command Access

Torus

Command Line: TORUS
Ribbon: Home tab > Modeling panel > Torus
Menu Bar: Draw > Modeling > Torus
Toolbar: Modeling

Options for Creating Solid Torus Primitives

It is a two-step process to create a solid torus. First, define the radial size by specifying its center point, then its radius or diameter. Second, define the size of the solid tube material by specifying its radius or diameter. The radial size of the torus is measured from the center point of the torus to the center point of the solid tube.
Instead of defining the size of a torus by its center point and radius or diameter, you can also define its size and location in 3D space by using other options: Three Points, Two Points, or Tangent to Two Objects and a Radius.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3P</td>
<td>Use to define the center of the torus by having its circular center pass through three points in space. Especially useful when positioning and sizing a torus based on existing 3D geometry.</td>
</tr>
<tr>
<td>2P</td>
<td>Use to define the diameter of the torus using two opposite points on its circular center. Especially useful when you do not know the location of the center point or you are positioning and sizing a torus based on existing 3D geometry.</td>
</tr>
<tr>
<td>Ttr</td>
<td>Use when you need the tubular shape to be tangent to two different edges and a specific radius.</td>
</tr>
<tr>
<td>radius</td>
<td>Use to define the tubular radius by picking a point in space or entering a specified value.</td>
</tr>
<tr>
<td>2Point</td>
<td>Use to define the tubular shape by picking two points to define the tubular diameter.</td>
</tr>
<tr>
<td>Diameter</td>
<td>Use to define the tubular diameter by picking two points in space or entering a specified value.</td>
</tr>
</tbody>
</table>

Procedure: Creating a 3D Torus Primitive

The following steps give an overview of creating a solid torus primitive.

1. Start the Torus command.
2. Specify the start position, orientation, and size of the torus. Do this by specifying the center point and then the radius or diameter. Or select one of the suboptions and respond to its requirements.
3. Specify the radius or diameter for the solid part of the torus.

Creating a Solid Pyramid

You use the Pyramid command to create a primitive that has a polygonal base with flat sides that transition in shape from the base to the top. The pyramid can transition from its base shape to a single point or to a shape smaller or larger than its base. By default, the polygonal base has four sides, but you can change that number based on your requirements.

In the following image, the two solid primitives on the left are being displayed partially transparent so you can see their initial creation starting plane. The two solid primitives on the right are examples of pyramids with more sides than the default value and different top conditions.
Chapter 1: Introduction to 3D Modeling

Command Access

Pyramid

Command Line: PYRAMID
Ribbon: Home tab > Modeling panel > Pyramid
Menu Bar: Draw > Modeling > Pyramid
Toolbar: Modeling

Options for Creating Solid Pyramid Primitives

The workflow and options for creating a pyramid is done by first specifying the center point and then a point on the polygon, much like drawing a 2D polygon. With the base shape defined, you then specify the height. The default direction of height is perpendicular to the base circular shape.

Instead of creating a pyramid based on its default prompts and options, you can select different suboptions to create the pyramid based on other design criteria.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edge</td>
<td>Use this option to specify the length of a flat segment on the polygon base. When clicking the points to define the size of a segment, you also set the position and orientation of the base polygonal shape.</td>
</tr>
<tr>
<td>Sides</td>
<td>Use this option to change the shape of the pyramid by changing the number of sides from the default of 4 to any value greater than 2 and less than 33.</td>
</tr>
</tbody>
</table>
### Option | Description
--- | ---
Circumscribed / Inscribed | Use this option to change which outer point you define when specifying the size of the base polygonal shape. Use Circumscribed to size the polygon from the center point to the midpoint of a flat segment on the polygon. Use Inscribed to size the polygon from the center point to the endpoint of a polygon segment.

Axis Endpoint | Use this option to specify the top center point of the pyramid. This sets the pyramid height and reorients the pyramid so its center axis extends from its base center point to the selected axis endpoint, in effect, rotating the pyramid to the new alignment.

Top Radius | Use this option when you want a pyramid shape with a flat top instead of one that comes to a point. With a smaller size value than the base, you create a pyramid that tapers in as it transitions from the base to the top. With a larger value, you create a pyramid that tapers out from the base to the top.

---
To change the number of sides or specify the edge length of a pyramid, select the corresponding option prior to specifying the center point.

You can use the Pyramid command to create objects like hexagon bar stock by specifying the top radius size to be the same as the base size.

---
### Procedure: Creating a 3D Pyramid

The following steps give an overview of creating a solid polygonal pyramid.

1. Start the Pyramid command.
2. Change the number of sides for the polygon base if the default value is different than your current requirements.
3. Specify the base polygonal shape's start position, orientation, and size. Do this by specifying the center point and then the radius to a point on the polygon shape that is circumscribed or inscribed. Or select the Edge suboption and specify the endpoints of one edge.
4. Specify the height to create a 3D pyramid where the sides converge to a point, or select the option Top Radius.
5. If you selected the option Top Radius, specify the radius value for the top.
6. Specify the height to the flat top of the pyramid.
Exercise: Create Solid Primitives

In this exercise, you create 3D solid primitives to visualize the layout of a room.

To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 1: Introduction to 3D Modeling. Click Exercise: Create Solid Primitives.


2. Make sure the 3D Modeling workspace is selected.

3. Make the Bed layer current.

4. On the ribbon, click Home tab > Modeling panel > Box.

5. To create the bed:
   - When prompted to specify the first corner, click the left corner of the bed (1).
   - When prompted to specify the other corner, click the opposite corner of the bed (2).
   - Enter 24 for the height.

6. Make the Lamp layer current.

7. For ease of selection in subsequent steps, on the ribbon, click the Home tab > View panel > 3D Wireframe.

8. On the Home tab, click Modeling panel > Cylinder.
9. To create a cylinder:
   ■ When prompted to specify the center point of the base, use the Center object snap and select the center of the circle (1).
   ■ When prompted to specify a base radius, use the Quadrant object snap and select a quadrant of the large circle (2).
   ■ Enter 3 for height.

10. Start the Cylinder command.
11. To create the lamp pole:
    ■ When prompted to specify the center point of the base, use the Center object snap and select the center of the circle (1).
    ■ When prompted to specify a base radius, use the Quadrant object snap and select a quadrant of the small circle (2).
    ■ Enter 60 for height.

12. On the Home tab, click View panel > Realistic.

14. To create the lamp shade:
    ■ When prompted to specify the center point of the base, enter S for sides.
    ■ When prompted for the number of sides, enter 12.
    ■ When prompted to specify the center point of the base, use the Center object snap and select the center of the cylinder.
    ■ Enter 12 when prompted to specify a base radius.
    ■ Enter T, for top radius, when prompted to specify height.
    ■ Enter 8 for the top radius.
    ■ Enter 12 for height.

15. Make the Light layer current.
17. To define the torus:
   ■ When prompted to specify a center point, enter 106,96,90.
   ■ Enter 9 when prompted for a radius.
   ■ Enter 1.5 when prompted for the tube radius.

18. On your own, complete the room by adding solids for the hutch, desk, and other lamp on the appropriate layers.

19. Close all files. Do not save.
Lesson: Mesh Primitives

Mesh modeling is a powerful digital prototyping process that enables you to create free flowing organic shapes in AutoCAD. You can create a free-form mesh model and convert it to a solid model without the restriction of solid modeling primitives.

Mesh modeling is far more versatile than solid modeling when creating organic free flowing shapes. The ability to seamlessly transition between mesh modeling, surface modeling, and solid modeling provides you with many design and manufacturing options. Mesh modeling can be very productive and has a shorter learning curve than other 3D modeling types.

This camera body model was made using mesh modeling

Objectives
After completing this lesson, you will be able to:

- Describe subdivision meshes and how they can be used in 3D design and visualization.
- Create primitive mesh shapes including Box, Cone, Cylinder, Pyramid, Sphere, Wedge, and Torus shapes.
- Create mesh surfaces including revolved, ruled, tabbed, and edged features.
About Subdivision Meshes

Mesh modeling enables you to approximate a smooth surface using a mesh of faces called subdivisions. The more subdivisions there are, the smoother the surface appears. Tessellation lines represent the visual boundaries of each subdivision. Each subdivision has one face, no less than three and no more than four edges, and a corresponding number of vertices. Each subdivision face, edge, or vertex can be edited independently by moving, rotating, or scaling it with the 3D-Gizmo.

The black lines on the model are called tessellation lines and visually represent the boundaries of each subdivision.

Definition of Mesh Modeling

Mesh modeling is like sculpting with a net that approximates almost any shape. Think of each hole in the net as a subdivision. The subdivisions can be set to small or large and provide a smooth or coarse approximation of the object you are designing.
Example of Subdivision Meshes

This camera body started as a basic box and was sculpted into this shape within a few minutes. It is not possible to create this shape using solid modeling alone. Using legacy surface modeling technology would take considerably more time and skill to achieve these results.

Creating Mesh Primitives

You can quickly create basic shapes using mesh primitives. These basic shapes can be modified extensively to create the organic models within your designs. You can set several mesh primitive options when you create them and change many of the options at any time during the design process.

The seven mesh primitive shape are box, cylinder, cone, sphere, pyramid, wedge, and torus. Use mesh primitives to increase your modeling productivity. Using predefined shapes enables you to move through the design process in fewer steps.
Command Access

Command Line: MESH
Ribbon: Mesh Modeling tab > Primitives panel > Mesh Box/Mesh Cylinder/Mesh Cone/
Mesh Pyramid/Mesh Sphere/Mesh Wedge/Mesh Torus

Menu Bar: Draw > Modeling > Mesh > Primitives

Command Access

Mesh Primitive Options

Command Line: MESHPRIMITIVEOPTIONS
Ribbon: Mesh Modeling tab > Primitives panel > Options arrow

Menu Bar: Draw > Modeling > Meshes > Primitives
Lesson: Mesh Primitives

Mesh Primitive Options Dialog Box

Use the Mesh Primitive Options dialog box to set the default values when creating new mesh primitives.

1. This menu shows the available mesh primitives.
2. Set values for the number of tessellation (white) lines for a new primitive.
3. Use this window to preview a new primitive. Right-click in the preview window to select display options.
4. Use this option to pan, zoom, and orbit in the preview window.
5. Select the smoothness value for the preview. Level 4 is the smoothest. This enables you to see what your primitive will look like when a specific smoothing level is applied.
6. Place a check mark in the box next to the Auto-update option to automatically update the preview window whenever a value is changed.

Setting the Default Smoothness for New Primitives

By default all new primitives are created with a smoothness level of 0. When you click a Mesh Primitive option on the ribbon, the first line of the command line indicates the Current Smoothness Level as shown below.

Current smoothness level is set to : 0

Enter an option [Box/Cone/Cylinder/Pyramid/Sphere/Wedge/Torus/Settings] <Box>

If you start the Mesh command on the command line, you can use the Settings option to change the default smoothing level. Note: This option is not available in the Mesh Primitives Options dialog box.
Process: Creating a Mesh Box Primitive

The following steps provide an overview of creating a mesh box primitive.

1. On the ribbon, click Mesh Modeling tab > Primitives panel > Mesh Box.

2. On the ribbon, click Render tab > Edge Effects panel > Isolines. This makes the tessellation lines visible on the model.

3. In the drawing area, specify the location of opposite corners for the box base.

4. In the drawing area, click and drag to define the height of the box or enter the height of the box.

5. The mesh box in the wireframe visual style is completed.
6. On the ribbon, click Render panel > Visual Styles panel > Conceptual.

7. The mesh box in the conceptual visual style is completed.

8. Select the box. In the Quick Properties panel, set the Smoothness to Level 2.

9. Close the Quick Properties panel.

10. The smoothed mesh box is completed.
Process: Creating a Mesh Cylinder Primitive

The following steps provide an overview of creating a mesh cylinder primitive.

1. On the ribbon, click Mesh Modeling tab > Primitives panel > Mesh Cylinder.

2. In the drawing area, specify the location of the center of the cylinder base.

3. In the drawing area, specify the radius of the cylinder.

4. In the drawing area, specify the height of the cylinder.

5. The mesh cylinder in the wireframe visual style is completed.

7. The mesh cylinder in the conceptual visual style is completed.

8. Select the cylinder. In the Quick Properties panel, set the Smoothness to Level 2.

9. Close the Quick Properties panel.

10. The smoothed mesh cylinder is completed.

Guidelines for Creating Mesh Primitives

Consider the following guidelines when creating mesh primitives:

- Create new primitives with a smoothness level of 0.
- Increase smoothness to level 1 or 2 when practical. Use level 3 and 4 only if the design requires it.
Creating Mesh Surfaces

Mesh surfaces are like sheets of net that you can shape to your needs. They are similar in look and name to legacy surface technologies, but are much more powerful. Mesh surfaces can be edited using the same commands as mesh primitives. Like legacy surfaces, mesh surfaces require other objects like lines, arcs, or polylines to be drawn first. These objects serve as the boundaries when creating the surface.

Command Access

Modeling Meshes

Command Line: RULESURF, TABSURF, REVSURF, EDGESURF
Ribbon: Mesh Modeling tab > Primitives panel > Revolved Surface/Edge Surface/Ruled Surface/Tabulated Surface

Menu Bar: Draw > Modeling > Meshes
Process: Creating a Ruled Surface Mesh

1. Create two bounding objects in different Z planes using lines, polylines, arcs, or splines.

2. On the ribbon, click Mesh Modeling tab > Primitives panel > Modeling, Meshes, Ruled Surface.

3. Select the first bounding object.

4. Select the second bounding object. The ruled surface is created.

6. Select the object. In the Quick Properties panel. Set the Smoothness to Level 2.

7. The ruled mesh surface is complete.

Guidelines for Creating Mesh Surfaces

Consider the following guidelines when creating mesh surfaces:

- Before the creation of new mesh surfaces, other objects must be created to serve as their boundaries.
- Legacy surfaces can be converted into mesh surfaces.
- Use the Thicken command with surfaces. Do not confuse it with the Thickness command.
- Use SURFTAB1 and SURFTAB2 system variables to control the initial mesh density prior to creating the mesh surfaces.
Exercise: Create Mesh Primitives

In this exercise, you create mesh primitives and adjust mesh primitive options to change the tessellation divisions for primitives. You also create mesh surfaces from existing objects.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 1: Introduction to 3D Modeling. Click Exercise: Create Mesh Primitives.

Create Mesh Primitives

1. Open M_Mesh-Primitives.dwg.
2. To create some basic mesh primitives:
   - Click the Mesh Modeling tab, Primitives panel > Mesh Box.
   - To specify the first corner of the box, click a point in a blank area of the drawing.
   - To specify the second corner of the box, click a point that is approximately 200 units in the X and Y directions.

3. To specify the height of the box, click a point approximately 200 units in the Z direction.

4. Examine the tessellation lines on the box primitive. The number of faces on each side of the box is controlled by the current settings in the Mesh Primitives Options dialog box. To review these settings:
   - On the Primitives panel, click Mesh Primitives Options. Note this is the small arrow that appears in the lower left corner of the Primitives panel.
   - In the Mesh Primitives Options dialog box, select the Box Primitive.
   - Note the values under Tessellation Divisions for Length, Width, and Height.
   - They will be equal to the number of faces on each side of the box you have drawn.
5. In the Mesh Primitives Options dialog box, click and drag in the Preview Window to view the box.
   - Set the Preview's Smoothness Level to Level 3.
   - Right-click the preview window, click Visual Styles > Conceptual.
   - Experiment with other Visual Styles settings and Preview Smoothness settings.

6. In the Mesh Primitives Options dialog box, with the Box primitive selected, enter 6 in the Width field and enter 10 in the Height field.
   - Click OK.
   - On the Primitives panel, click Mesh Box.
   - Create another box approximately 200 x 200 x 200.
   - Note the differences in tessellation lines.

7. To check the default smoothness level for the primitives:
   - On the Status Bar, turn on Quick Properties.
   - Select the box primitive to reveal the Quick Properties palette.
   - The Smoothness value should be set to None by default.

8. Press ESC to clear the selection.
9. To change the default smoothness level for primitives:
   - On the command line, enter Mesh.
   - Use the Dynamic Input menu to select the Settings option, or enter SE for the Settings option.
   - To specify the Level of Smoothness, enter 4.
   - Enter B for the Box option.
   - Create another box approximately 200 x 200 x 200 units.

10. Select the new box primitive. The Quick Properties palette reveals the default smoothness value of Level 4.

11. To set the default smoothness level to None:
   - On the command line, enter Mesh.
   - Use the Dynamic Input menu to select the Settings option, or enter SE for the Settings option.
   - To specify the Level of Smoothness, enter 0.
   - Enter B for the Box option.
   - Create another box primitive.
   Note: When changing the smoothness level setting, you must create a primitive after changing the setting, otherwise the settings change will not be saved.

12. Erase all but one of the box primitives.

13. Using the other mesh primitives tools, create one of each of the other types of primitives. Note: The process for creating mesh primitives are identical to the steps to create solid primitives.

14. Delete all the primitives. Make certain not to delete the geometry shown in the following illustration.

Exercise: Create Mesh Surfaces
In this exercise, you create mesh surfaces from existing geometry.

1. Continue where you left off from the previous exercise, or open M_Mesh-Primitives.dwg if you did not complete the previous exercise table.

2. Zoom in on the profile as shown.
   - On the Primitives panel, click Revsurf.
   - Select the profile (1) to revolve.
   - Select the axis of revolution (2).
3. To complete the revolve surface:
   - Press ENTER to use the default start angle of 0.
   - Press ENTER to use the default included angle of 360.

4. The resulting surface is not as round as it should be. You can control this result by adjust the SURFTAB1 or SURFTAB2 system variables. In this example the SURFTAB1 system variable needs to be changed.
   - Delete the revolved surface.
   - Enter SURFTAB1 and press ENTER.
   - Enter 16 and press ENTER.
   - Repeat the REVSURF command on the profile.
   - The resulting surface, while still faceted is, better reflects the design intent.

5. To create a mesh surface between edges:
   - Zoom into the profile shown.
   - Set SURFTAB2 to 16 so that the tesselation values are the same in both directions.
   - On the Primitives panel, click EDGESURF.
   - Note the command line, indicates the current wireframe density as SURFTAB1=16 and SURFTAB2=16.
   - Select the edges for the surface in the order shown.
6. The surface mesh appears as shown.

7. To create a ruled surface:
   - Zoom into the two circles as shown.
   - On the Primitives panel, click RULESURF.
   - Select the two circles.

8. The ruled surface mesh appears as shown.

9. To create a tabulated surface:
   - Zoom into the profile as shown.
   - On the Primitives panel, click TABSURF.
   - Select the profile (1).
   - Select the line (2) as the direction vector.
10. The tabulated surface mesh appears as shown.

11. Close all files, do not save changes.
Lesson: Working in 3D

This lesson describes the 3D coordinate system and how to define a custom coordinate system, control the display of the coordinate system icon, and acquire points in 3D space.

Being able to adjust the current coordinate system for geometry creation and to acquire the proper point in 3D space is an important part of being able to create your design as quickly and as efficiently as possible.

In the following image, the same model is shown with different active coordinate systems and tracking a point in 3D space.

Objectives

After completing this lesson, you will be able to:

- Describe the relationship of the Cartesian coordinate system and 3D design.
- Change the orientation and location of the coordinate system.
- Change the display of the UCS icon.
- Describe how to change the coordinate systems dynamically while in a geometry creation or modification command.
- Acquire a point in 3D space by tracking or filtering from other points.
About the Cartesian Coordinate System

When you create 2D drawings, you create geometry on the XY plane. In many cases, the only time you give the coordinate system any thought is when you are entering an absolute or relative point. As you create geometry in 3D, you will need to reorient the coordinate system to create and modify the geometry. In this section of the lesson, you learn about the Cartesian coordinate system and how it can help you create 3D designs.

In the following image, the icons show the direction of the X, Y, and Z axes of the Cartesian coordinate system based on the current viewing direction. The left icon is shown in its shaded mode and the right one in its wireframe form.

![Cartesian Coordinate System](image)

Definition of the Cartesian Coordinate System

Computer-aided drafting and design (CADD) systems base their positioning of points in 3D space on the Cartesian coordinate system. The Cartesian coordinate system is composed of three axes (X, Y, and Z) at 90° to each other. These intersecting axes define the origin point for the coordinate system and three flat planes. The origin point is the location where each axis value is 0 (zero). The three planes are defined by pairs of axes which create the XY, XZ, and YZ planes.

There is one preset coordinate system and you cannot change it. This coordinate system is referred to as the world coordinate system (WCS). When you begin to create 3D models, you will find working only from the WCS to be challenging at times. To make it easier to create and modify geometry, you can define a user coordinate system (UCS). You can define a UCS at any place or orientation in space and you can define as many as you need. When you define a new UCS, you define a new origin location and direction for the X, Y, and Z axes. The way you define a new coordinate system depends on the geometry you have created and the geometry you are trying to create or modify. In some cases, you will have the coordinate system automatically change based on a flat face you hover your cursor over. In other cases, you will manually reorient and reposition the coordinate system. This manual adjustment can be as simple as moving the origin to a new location, reorienting it by picking three points in space, or rotating its alignment around one axis.

By default, the drawing displays an icon to help you visualize the orientation of the current coordinate system and its origin location. This default icon labels the X, Y, and Z axes and also color codes them: Red for the X axis, green for the Y axis, and blue for the Z axis.
The following image illustrates the planes defined by the different axes of the Cartesian coordinate system. Plane 1 is the XY plane defined by the X and Y axes. Plane 2 is the YZ plane defined by the Y and Z axes. Plane 3 is XZ plane defined by the X and Z axes.

Example of the Need to Change the Coordinate System

When creating a 3D design, you sometimes need to create solid or 2D geometry starting on a face that is not in line with the world coordinate system (WCS). In those cases, you need to define your own coordinate system to achieve the needed results. In the following image, the icon shows the axis orientation for the WCS. The different geometry was drawn on the different faces of the models by changing to a user coordinate system. For example, the circle was drawn on the angled face using standard 2D drawing procedures after the coordinate system’s X and Y axes were set in alignment with the edges of the face.
Changing the Coordinate System

In this section, you learn about the UCS command. This includes learning how to access the command, the procedure, and the workflow for using the command, and the most often used options of the command.

When you place objects into your 3D model, your working planes tend to be different than the objects you need to place, thus making object placement more difficult to do. Therefore, you need to be able to define your own coordinate system(s) in order to make object placement easier. The UCS you define then enables you to create the geometry you need in the appropriate location and orientation.

In the end, the process of creating a 3D model can be made much simpler when you break down your model into smaller flat sections within the WCS.

In the following illustrations, different coordinate system orientations and alignments are shown simultaneously on two models. One shows UCS placement on a house and the other shows UCS placement on a mechanical part. Though only one coordinate system can be active at any one time, these images illustrate how different the orientation and origins of user coordinate systems can be from the WCS.

Command Access

UCS

Command Line: UCS
Ribbon: View tab > Coordinates panel > UCS

Menu Bar: Tools > New UCS
Toolbar: UCS
Toolbar: UCS II
Options for Defining a UCS

Following the typical workflow and command options, you either reposition the origin of the coordinate system while keeping its current X, Y, Z axis alignment, or you completely reorient and reposition the coordinate system based on three points in space. To reposition the origin, you start the UCS command, click the new origin point, and then press ENTER. To reorient and reposition, click a point on the X axis after clicking the new origin point, and then click a third point to define the XY plane.

Instead of defining a new UCS based on the default prompts and options, you can define the UCS based on other criteria. The following options are some of the most frequently used for defining a new UCS.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>World</strong></td>
<td>Use to set the coordinate system back to the world coordinate system.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Named UCS</strong></td>
<td>Use to display the UCS dialog box, save a UCS, and activate a saved UCS.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Previous</strong></td>
<td>Use to step the coordinate system back to the alignment and position it was previously.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Face</strong></td>
<td>Use to align the coordinate system to a selected flat surface or solid face.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Object</strong></td>
<td>Use to align the coordinate system to a selected object.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>View</strong></td>
<td>Use to align the coordinate system to the XY plane perpendicular to your viewing direction.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Origin</strong></td>
<td>Use to move the coordinate system origin to a selected point.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Z Axis</strong></td>
<td>Use to align the coordinate system to a point and specified Z axis.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>3 Point</strong></td>
<td>Use to align the coordinate system to point and specified X and Y axes.</td>
</tr>
<tr>
<td>Icon</td>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="X Icon" /></td>
<td>X</td>
<td>Use to rotate the coordinate system around the X axis.</td>
</tr>
<tr>
<td><img src="image" alt="Y Icon" /></td>
<td>Y</td>
<td>Use to rotate the coordinate system around the Y axis.</td>
</tr>
<tr>
<td><img src="image" alt="Z Icon" /></td>
<td>Z</td>
<td>Use to rotate the coordinate system around the Z axis.</td>
</tr>
<tr>
<td><img src="image" alt="Apply Icon" /></td>
<td>Apply</td>
<td>Use to apply the current UCS setting to all viewports or a specified viewport.</td>
</tr>
</tbody>
</table>

**Procedure: Creating a User Coordinate System**

The following steps give an overview of creating a user coordinate system.

1. Determine the orientation needed for the UCS.

![Image of 3D model with UCS orientations](image)

2. Start the UCS command option based on how you will orient the UCS.

![Image of 3D model with UCS orientations](image)
3. Create the needed geometry.

Changing the UCS Icon Display

While creating a 3D model, you may encounter times when you want the coordinate system icon to display a certain way, in a specific location, or not at all. To change the display of the coordinate system icon, you need to access the Ucsicon command and apply the options available for changing its display. This section of the lesson covers how to access the command, its options, and the standard procedure for its use.

In the following images, the UCS icon is shown in two different locations. Where it is set to display at the 0,0,0 point for the three axes, the display of the icon is visually disruptive to the model view. In the image on the right, it is forced to display in the lower-left corner of the viewport where it does not disrupt the model view.

Command Access

UCSICON

Command Line: UCSICON
Menu Bar: View > Display > UCS Icon
Options for Changing the UCS Icon Display

You can use the following options with the command.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>On</td>
<td>Use to turn on the display of the UCS icon.</td>
</tr>
<tr>
<td>Off</td>
<td>Use to turn off the display of the UCS icon.</td>
</tr>
<tr>
<td>All</td>
<td>Use when you have your drawing window split into multiple viewports. Select this option before one of the other options to have that option apply to all viewports.</td>
</tr>
<tr>
<td>Noorigin</td>
<td>Use to have the UCS icon always display in the lower-left corner of the viewport.</td>
</tr>
<tr>
<td>Origin</td>
<td>Use to have the UCS icon display at the origin location of the current coordinate system. If the origin is too close to the edge of the viewport or outside of the area being displayed, the UCS icon then is displayed in the lower-left corner.</td>
</tr>
<tr>
<td>Properties</td>
<td>Use to display the UCS Icon dialog box and set the style, size, and color of the UCS icon.</td>
</tr>
</tbody>
</table>

The options described above only appear when the UCSICON command is accessed from the command line. Other UCS related buttons apply to specific functionality of the UCS command.

Different coordinate system icons are displayed in paper space and model space. In both cases, a plus sign (+) appears at the base of the icon when it is positioned at the origin of the current UCS. The letter W appears in the Y portion of the icon if the current UCS is the same as the world coordinate system.
Procedure: Setting the UCS Icon Display

The following steps give an overview of setting the display of the UCS icon.

1. Start the Ucsicon command from the command line or click the UCS Icon Properties button on the ribbon.
2. Select the properties options to change the style, size, or color of the UCS icon.
3. Specify the display of the UCS icon at the origin or no origin.
4. Toggle the display of the UCS icon on or off.
Changing the Coordinate System Dynamically

Whether you are initially creating 3D models or 2D geometry in 3D space, the alignment of the coordinate system plays a crucial role in achieving the required results. While in a command to create new geometry, you have the option to dynamically change the coordinate system. For this option to be available, you need to have Dynamic UCS turned on. You can view and change the Dynamic UCS setting through the status bar's DUCS button.

With Dynamic UCS turned on, hovering your cursor over an existing flat face of a solid model while in a command that creates new geometry causes that face to highlight and the crosshairs to orient on that face.

If you click to define the starting point for that command while the face is highlighted, then a new UCS is temporarily defined for the duration of creating that new geometry. When you complete the command, the coordinate system that was active prior to creating that new geometry is activated again. This temporary dynamic coordinate system defines its XY plane to be coplanar to the highlighted face.

In the following image, a circle is shown being created on a face that was not in alignment with the coordinate system when the command was initially executed. The UCS was dynamically defined based on the highlighted face.

Command Access

Dynamic UCS Icon

Command Line: UCSDETECT
Status Bar: or
Procedure: Dynamically Changing the UCS

The following steps give an overview for dynamically changing the UCS.

1. Execute a command to create new 2D or 3D geometry.

2. Ensure Dynamic UCS is on by viewing the Allow/Disallow Dynamic UCS button on the status bar. Turn it on if it is currently off.

3. Hover your cursor over the flat face that you want to begin drawing on. The edges of an acquired face display as dashed lines.

4. Click to specify the start point of the new geometry. While the face is highlighted, you can object snap to or track from points and still have the UCS align to that face.

5. Enter the remaining values and input required to create the new geometry and finish the command.
Acquiring Points in 3D Space

You specify points in 3D space in much the same manner as in 2D space, except you supply a third value for the Z axis. If you want to type in an absolute or relative coordinate value, you include a Z value by entering the coordinate as X,Y,Z. You can also track in 3D space by combining the settings for running object snap, object snap tracking, and polar tracking or ortho. When tracking through a point not on the current coordinate system's XY plane, you track parallel to one of the current coordinate system axes. Another useful method of acquiring an exact location in 3D space is to use coordinate filters. Through the use of filters, you specify a point by combining the X, Y, and Z values from other specified point locations.

You will find the process of creating your design in 3D easier and quicker if you can quickly establish the correct location in 3D space for your design geometry.

In the following image, the start point for a new line is being tracked in the positive Z direction.

About Coordinate Filters

You use coordinate filters to specify a point relative to a collection of other points or a set distance from a specific point. Coordinate filters are also referred to as point filters. You access point filters from the Object Snap shortcut menu (SHIFT+right-click) or by entering one of the options when the active command prompts you to specify a point.

When you activate a filter and snap to a point or enter a value, you are specifying what the value should be for that filter coordinate. For example, if you use the .Z (the "." denotes a filter) filter and snap to the corner of a 3D model, you return the Z value from that corner. You would then need to specify the X and Y values. You could specify those values by snapping to another location, entering their values, or using their respective filters and snapping to two other locations. The combination of the filtered Z value and the X and Y values would constitute the location of the new point.

In the following image, a set of solid models is displayed in four viewports showing the top, front, right side, and isometric directional views. The center of the sphere was based on the point filters and object snaps as identified in the isometric view. The top view also shows the X and Y filter locations and the right side view also shows the Z filter location.
### Coordinate Filter Options

Use the following options to filter coordinate values.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.X</td>
<td>Use to snap to a point and only return its X value and then specify or filter for the Y and Z values.</td>
</tr>
<tr>
<td>.Y</td>
<td>Use to snap to a point and only return its Y value and then specify or filter for the X and Z values.</td>
</tr>
<tr>
<td>.Z</td>
<td>Use to snap to a point and only return its Z value and then specify or filter for the X and Y values.</td>
</tr>
<tr>
<td>.XY</td>
<td>Use to return the X and Y values of an existing point. You then specify or filter for the Z value.</td>
</tr>
<tr>
<td>.XZ</td>
<td>Use to return the X and Z values of an existing point. You then specify or filter for the Y value.</td>
</tr>
<tr>
<td>.YZ</td>
<td>Use to return the Y and Z values of an existing point. You then specify or filter for the X value.</td>
</tr>
</tbody>
</table>

If you are using point filters for the X or Y value but specifying the remaining coordinate values, you need to enter a value as a placeholder for the X or Y. So if you are using the .X filter and you want to enter an absolute Y and Z value, you need to enter a value for X. For example, the Y and Z values both need to be 5 and the X filter for the required corner returns 11.65. When prompted for the YZ, you enter 1,5,5. The 1 in this case acts as a placeholder and is automatically substituted with 11.65. In this case, 1 was used as the placeholder, but any number could be used.
Procedure: Tracking in 3D Space

The following steps give an overview for using 3D tracking to acquire points.

1. To track from an existing point, you must first be prompted by a command to specify a point.
2. Turn on object snaps and object snap tracking as well as polar tracking or ortho and set them with your required values and options.
3. Acquire the tracking point by passing your cursor over an object snap location on the geometry you want to track.

4. Track in any 3D direction from the acquired point and either click to specify the location or enter a distance value.

Procedure: Filtering Coordinate Points

1. To use point filters, you must first be prompted by a command to specify a point.
2. Decide what you already know, or have available to you, as it relates to the geometry of the drawing. Then decide what you are trying to find regarding the new point being specified.
3. Execute the proper point filter based on what you decided in the previous step.
4. Specify an absolute value or snap to another point to return its corresponding coordinate value.

Guidelines

- If you experience problems with displaying objects, snapping to objects, or using object tracking while a 3D visual style is active, switch to the 2D Wireframe visual style and then switch back to a 3D visual style.
- When working in a 3D view, reducing the number of active object snaps will also reduce the number of inadvertent point acquisitions.
Exercise: Work with the UCS

In this exercise, you use the options of the UCS command to create 2D and 3D geometry on different planes of a solid model. The planes created provide the base for adding additional features or solids in different orientations.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 1: Introduction to 3D Modeling. Click Exercise: Work with the UCS.


2. To turn off the Dynamic UCS, do the following:
   - On the status bar, if the Allow/Disallow Dynamic UCS button is selected, click to turn off Dynamic UCS.
   - If the button is not selected, Dynamic UCS is already turned off.

3. On the ribbon, click Home tab > Draw panel > Circle.

4. To create a circle, do the following:
   - Draw a circle near the UCS icon as shown. Notice the orientation of the circle relative to the solid model.

5. To create a new UCS, do the following:
   - On the View tab, click Coordinates panel > 3-Point.
   - Using the endpoint or intersection object snap, select the points indicated in the order shown.

6. Start the Circle command.
7. To create a profile on the angled face, do the following:
   ■ When prompted for a centerpoint, select the approximate center of the angled face, or you can use the Mid Between 2 Points object snap to obtain the centerpoint of the face.
   ■ When prompted for the radius, click the face to create the circle.

8. On the Home tab, click Modeling panel > Press/Pull.
9. To presspull the circle, do the following:
   ■ Select a point inside the circle and enter -5.
   ■ Press ENTER.

10. To align the UCS to a face, do the following:
    ■ On the View tab, click Coordinates panel > Face.
    ■ Select a point on the face of the part as shown.
    ■ Press ENTER to accept the orientation.

11. Draw and presspull the rectangular slot as shown.

12. If necessary, adjust your isometric view to see the three cylindrical features on the right side.
13. To orient the UCS, do the following:
    ■ On the View toolbar, click Coordinates panel > 3 Point.
    ■ When prompted for a new origin point, using the Center object snap, select the base of the left cylinder.
    ■ When prompted for a positive location on the X axis, using the Center object snap, select the base of the right cylinder.
    ■ When prompted for a positive location on the Y axis, using the Center object snap, select the top of the left cylinder.
Lesson: Working in 3D

14. To save the UCS for future use, do the following:
   ■ On the View tab, click Coordinates > Named to display the UCS dialog box.
   ■ Right-click the Unnamed UCS and click Rename.
   ■ Enter Ribs for the new name.
   ■ Click OK.

15. Start the Rectangle command.

16. To create 2D profile geometry for the rib, do the following:
   ■ When prompted for the first corner, enter 0,0.
   ■ When prompted for the other corner, enter @26,10.

17. On the Home tab, click Modeling panel > Press/Pull.

18. To extrude the profile, do the following:
   ■ Select a point inside the profile.
   ■ Move the cursor in the positive Z axis direction.
   ■ Enter 2. Press ENTER.

19. Close all files. Do not save.
Exercise: Use a Dynamic UCS

In this exercise, you use a Dynamic UCS to draw 3D primitives and 2D geometry.

2. To turn on Dynamic UCS:
   - On the status bar, select Allow/Disallow Dynamic UCS to turn Dynamic UCS on.
   - If Allow/Disallow Dynamic UCS is highlighted, Dynamic UCS is on.

3. On the Home tab, click Modeling panel > Box.

4. To draw a box on the angled face:
   - When you position your cursor over the angled face, the UCS icon reorients to the new face.
   - Click two points as indicated to create the rectangle.
   - Enter 20 in the dynamic input field for the height.
   - Press ENTER.

5. Start the Circle command.

6. To draw a circle on the main solid:
   - As you position the cursor for the center point, as shown, the cursor flips to indicate the new UCS.
   - Select a point near the point indicated.
   - Enter 5.
   - Press ENTER.
7. Click Render tab > Visual Styles panel > X-Ray.

![Visual Styles panel](image)

8. On the Home tab, click Modeling panel > Extrude.

9. To extrude the circle:
   - Select the circle.
   - Press ENTER.
   - Select the corner endpoint as shown.

![Extrusion](image)

10. Close all files. Do not save.
Lesson: Introduction to Free-Form Design

This lesson provides a brief overview to the free-form design process and some of the principles on which it is based.

If you look around at the products and structures that surround you, you will see more prevalent uses of organic free-from shapes. They are being used in all design disciplines and industries from automotive to architectural.

Objectives

After completing this lesson, you will be able to:

■ Describe free-form design.
■ State the overall process and methods involved in creating free-form designs.
■ Create a simple free-form design.
About Free-Form Design

All designs, from the simple to the complex, begin with an idea. Whether an automobile, building or structure, or consumer product, most products are translated into reality using a design process. This process usually involves instructions, rules, or guidelines that aid in the creation of a product design. In some design systems, examples of these rules or guidelines can be seen in profile-based 3D shapes that are extruded or revolved and combined with other profile based features to create complex parametric 3D designs.

While these approaches have their place in the design world and are still widely used, free-form design methods are intended to simplify some of the traditional procedures required to create these designs. By simplifying the process, you free the designers to focus on their vision of the shape that they are seeking rather than the rules or guidelines that they must follow to achieve the result.

In the following illustration, an office chair is shown in both a rendered and a wireframe format. These illustrations show examples of free-form design that result in sculpted surfaces.

Definition of Free-Form Modeling

When you use free-form design techniques in AutoCAD, you are in effect using your computer's mouse and monitor to digitally sculpt your model. You scale, adjust proportion, and position objects on screen as if they were in front of you. Mesh modeling tools and techniques in AutoCAD enable digital sculpting through unique features and tools, so you can make traditionally simple primitives into more complex free-form shapes.
In the following illustrations, free-form modeling is used to create an organic looking structure from a simple box primitive.

Examples of Free-Form Design

An example of free-form design that is used in a real-world design process could involve an architectural firm that is competing to design and build a public park and new central structure. Rather then utilizing the more traditional approaches to design, the architect or designer would use the free-form modeling process to create organic, free-flowing shapes that would not only capture the public's imagination and attention, but also serve as a challenge to the status-quo of traditional design methods potentially influencing future designs for surrounding structures.

In the following illustration, free-from design techniques are used to show a concept of a scooter.
Using Free-Form Design

Creating free-form designs is a process that involves different methods and approaches. The methods that you choose depend largely on what you are trying to accomplish. In general, you begin by creating 3D mesh primitives or solid primitives, and depending on what you are trying to accomplish, possibly converting some solids or surfaces to mesh objects.

Once you have created the geometry, you use free-form design tools to digitally sculpt the object into the desired shape. In much the same way that you would manually sculpt clay by pulling and stretching various portions or by applying creases along certain edges, the free-form modeling tools that are available enable you to digitally sculpt your geometry into the required shape.

After you have arrived at the desired shape, additional tools are available that enable you to convert the objects to solids or surfaces using different settings that create smooth or faceted objects. Once converted, the objects can then be used in additional downstream processes such as 3D printing.

In the following illustration, a free-form design is exported to Revit® for additional design refinements.

Process: Using Free-Form Design

The following steps give an overview for using free-form design methods.

1. Begin by creating mesh objects or solids. You can create them by using the available primitives or by converting existing solids or surfaces.
2. Use Mesh, Mesh Edit, and Subobject tools to edit the meshes or solids as required to define the shape.

3. Continue to sculpt and refine the design.

4. Convert the mesh objects to solids or surfaces to use the additional solid editing tools or applications as required. Use the free-form design as the basis for the final manufacturing design.
Guidelines

Consider the following guidelines when using the free-form design tools in AutoCAD.

- Some of the same free-form design methods and tools can be used on both mesh objects and solid objects.
- Free-form design in AutoCAD is intended to enable you to focus on the conceptual aspect of your designs. Additional tools, applications, and processes may be required downstream to create the required construction or manufacturing documentation.
- Experiment with various methods, object types, and processes to achieve the desired shapes. By definition, free-form design should minimize restrictions and enable you to experiment outside of the constraints of mainstream design processes.
Exercise: Use Free-Form Design

In this exercise, you create a conceptual design of a barstool using simple free-form design techniques.

The completed exercise

Completing the Exercise
To complete the exercise, follow the steps in this book or in the onscreen exercise. In the onscreen list of chapters and exercises, click Chapter 1: Introduction to 3D Modeling. Click Exercise: Use Free-Form Design.

1. Open C_Use-Free-Form-Design.dwg. Before continuing with this exercise, activate the 3D Modeling workspace. Additionally, in the Options dialog box > 3D Modeling tab > Deletion Control While Creating 3D Objects should be set to Delete Profile Curves.

2. To reveal the object type and some properties:
   - Position your cursor over the model, but do not select it.
   - A tooltip appears that indicates the object is a Mesh, has a Smoothing Level of 0, and contains 144 faces.
3. To change the mesh objects Smoothness level:
   - On the status bar, click Quick Properties if it is not already active.
   - Select the mesh object.
   - On the Quick Properties palette, Smoothness list, select Level 2.

4. Next, you use some standard free-form design techniques to sculpt the barstool.
   - On the ViewCube, click Right.
   - Right-click the ViewCube. Click Parallel.
   - On the Mesh Modeling tab, click Subobject panel > Edge.
   - CTRL+select the edges as shown. Hint: Hold the CTRL key down while drawing an implied window left to right.

5. To reposition the edges:
   - Position your cursor over the Z axis of the 3D-Gizmo. The Z axis turns yellow to indicate that it is selected and that movement is being limited to that direction.
   - Click and drag in a downward direction to position the edges as shown.
   - Press ESC to clear the selection.
6. Use the same technique to reposition the edges as shown in the following illustration. Press ESC to clear the selection.

7. On the ViewCube, click Home to return to the home view.

8. To sculpt the back support area of the barstool:
   - Rotate your view to show the tessellation lines of the seat surface.
   - CTRL+select the tessellation lines as shown.
   - Position your cursor over the Z axis of the 3D-Gizmo.

9. Click and drag the edges in the positive Z direction to sculpt the back support area of the stool as shown.

10. Press ESC to clear the selection.
11. Select the barstool and use the Quick Properties palette to set the smoothing to level 4.

12. Next, you convert the object into a solid. However, before doing so, it’s a good idea to make a copy of your mesh. If you need to convert back form a solid to a mesh, the resulting mesh is not always identical in how it is tessellated. By making a copy of the mesh, you preserve it in its original state before you convert it.
   - Create a new layer to place the mesh copy on, and freeze the layer.
   - Using the standard Copy method, make a copy of the barstool mesh object in place, and place the new copy on the frozen layer.
   - On the Mesh Modeling tab, Convert Mesh panel, make sure Smooth, optimized is the active conversion setting.
   - On the Mesh Modeling tab, click Convert Mesh panel > Convert to solid.
   - Select the original mesh barstool object. Press ENTER.

13. To slice the solid object:
   - Open the Layer Properties Manager and thaw the SliceObjects layer.
   - On the Home tab, click Solid Editing panel > Slice.
   - Select the solid barstool. Press ENTER.
   - Right-click anywhere in the graphics window. Click Planar Object.
   - Select the red circle.
   - Press ENTER again to accept the default option to keep both sides.

14. Freeze the SliceObjects layer.

15. On the View tab, click 3D Palettes panel > Materials if the Materials palette is not already turned on.
16. To apply materials to the elements of the barstool:
   - Drag and drop the Furnishings.Fabrics.Leather.Black material on the barstool seating surface.

17. Close all files. Do not save.